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1. Introduction 

1.1. Scope of the document 

The MarineData4Asia training event, promoted by Mercator Ocean International in the framework of the Copernicus 
Marine Service, aims at increasing user uptake and awareness in Asian countries: to achieve this target, the training 
event shows how to use technologies such as QGIS for manipulating the Copernicus Marine Product Catalogue, with the 
scope to provide examples on ecosystem monitoring studies and to focus on the main marine and coastal challenges 
impacting the continent. 

In this tutorial, we will learn how to: 

• Monitor the El Niño (and La Niña) event by computing SST anomalies to visualize the relevant pattern in the 
Pacific Ocean and for computing metrics in the Niño3.4 region. 

• Visualize the Copernicus Marine products in the Indian Ocean, extracting EOV values in same specific locations. 

• Interpolate SST values in specific grid at given resolution to support additional data analysis (e.g., validation). 

Technical material here described is complementary to the tutorial videos available on the Copernicus Marine Service 
YouTube page. 

1.2. Focusing on El Niño event in 2023 in the tropical Pacific Ocean region 

The El Niño Southern Oscillation (ENSO) is an interannual climate pattern, that is characterized by changes in winds and 
sea surface temperatures in the tropical Pacific Ocean, with global impacts on weather, wildfire, ecosystems and 
economy [1]. El Niño and La Niña are 2 phases of ENSO [2]: 

• El Niño is characterized by unusually warm ocean temperatures in the Equatorial Pacific; 

• La Niña is, on the contrary, characterized by unusually cold ocean temperatures. 

As described in [3], ENSO has a robust impact on East Asia climate, mainly by modifying the atmospheric circulation over 
the Western North Pacific and circulation in the Philippine Sea and Kuroshio. During El Niño winters, wind anomalies 
from the South embedded in the Western part of anticyclonic circulation insisting in the basin bring warm and moist air 
to East Asia, leading to abnormal wet and warm climate. Opposite changes are observed during La Niña.  

Mercator Ocean International is operationally monitoring current El Niño event since its appearance in Spring 2023 
through dedicated bulletins that show the evolution of sea surface temperature (SST) anomalies on monthly basis [4]. 

During this QGIS training session, we will focus on how to use the Copernicus Marine Service model data provided by 
the Global Monitoring and Forecasting Centre (GLO-MFC) to monitor El Niño evolution since June 2023 in the Pacific 
Ocean (Figure 1). Practical examples on how to visualize sea surface essential ocean variables (EOV) in some peculiar 
locations in the Indian Ocean will be also given, to conclude then on how to exploit geospatial analysis tools for 
interpolating on a given regular grid SST values from both model and satellite observations. 

 

Figure 1: Application area considered during the MarineData4Asia Copernicus Marine Training Session. 

https://www.youtube.com/@copernicusmarineservice1453/videos
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2. Copernicus Marine Service Products, contextual 
information and GIS tool 

2.1. Copernicus Marine Service products  

2.1.1. List of used products, datasets and files 

In this training on MarineData4Asia, we will focus on the tropical Pacific Ocean region, to understand how the evaluate 
the El Niño conditions during Jun-Nov 2023 and impacts in the Indian Ocean. In the following, we list the products and 
associated datasets and files as used during the training session.  

In the following, the bounding boxes for the reference target regions used in this tutorial: 

• Pacific Ocean: 180°W to 180°E; 60°S to 60°N. 

• Indian Ocean: 30°E to 120°E; 30°S to 30°N. 

Additionally, it is reported the full list of Copernicus Marine products downloaded and used from the Marine Data Store. 

• GLOBAL_MULTIYEAR_PHY_001_030, which is the Global Ocean Physics Reanalysis product (GLO-PHY MY). We 
will use the climatological (climatology_P1M-m) dataset for temperature (thetao) related to the period from 
June to November 2023.  

o Dataset: cmems_mod_glo_phy_my_0.083-climatology_P1M-m 
▪ File: CMEMS_Pacific-Ocean_thetao_clim.nc 

(downloaded through the Copernicus Marine Toolbox, whose link is reported in Appendix). 

• GLOBAL_ANALYSISFORECAST_PHY_001_024, which is the is the Global Ocean Physics Analysis and Forecast 
(GLO-PHY NRT). We will use the monthly means (anfc_0.083deg_P1M-m) dataset for temperature at 0.5 m 
depth (thetao), related to the period from June to November 2023. Additionally, we will use daily means 
(anfc_0.083deg_P1D-m) fields for temperature (thetao) and salinity (so) at 0.5 m depth, and mixed layer depth 
(mlotst) related to the period 01-07/11/2023.  

o Dataset: cmems_mod_glo_phy-thetao_anfc_0.083deg_P1M-m 
▪ File: cmems_mod_glo_phy-thetao_anfc_0.083deg_P1M-m_202306-202311.nc 

o Dataset: cmems_mod_glo_phy-thetao_anfc_0.083deg_P1D-m 
▪ File: cmems_mod_glo_phy-thetao_anfc_0.083deg_P1D-m_SST-20231101-20221107.nc 

o Dataset: cmems_mod_glo_phy-so_anfc_0.083deg_P1D-m 
▪ File: cmems_mod_glo_phy-so_anfc_0.083deg_P1D-m_SSS-20231101-20221107.nc 

o Dataset: cmems_mod_glo_phy_anfc_0.083deg_P1D-m 
▪ File: cmems_mod_glo_phy-so_anfc_0.083deg_P1D-m_MLD-20231101-20221107.nc 

(downloaded through the Copernicus Marine Data Store, using the subset function). 

• SST_GLO_PHY_L4_NRT_010_043, which is the ODYSSEA Global Sea Surface Temperature Gridded Level 4 Daily 
Multi-Sensor Observations. We will use the daily fields for the period 01-07/11/2023. 

o Dataset: cmems_obs-sst_glo_phy_nrt_l4_P1D-m 
▪ File: cmems_obs-sst_glo_phy_nrt_l4_P1D-m_SST-20231101-20221107.nc 

2.1.2. How to download data from the Copernicus Marine Service? 

Here, we will shortly demonstrate the steps to download the Global Model data listed in Section 2.1.1 from the 
Copernicus Marine Service, using the new recent tools provided by the Service: the Copernicus Marine Toolbox and the 
function subset available directly in the Copernicus Marine Data Store.  

2.1.2.1. Example on how to use the Copernicus Marine Toolbox 

The Copernicus Marine Toolbox is the new client that will be used to explore and download the Copernicus Marine data. 
In the reference link, a detailed description of the steps to install and run it is given; additional details are provided at 
the Jupyter Notebook video-tutorial given during this MarineData4Asia Training session. In this section, we only 
illustrate the basic commands run through a Jupiter Notebook for downloading GLO-PHY MY data as described in Section 
2.1.1. 

For running this example, you first need to install and configure the Copernicus Marine Toolbox in your local machine. 
Once done, you might simply follow these basic steps for getting the “CMEMS_Pacific-Ocean_thetao_clim.nc” file from 
the Copernicus Marine Data Store. 

https://data.marine.copernicus.eu/product/GLOBAL_MULTIYEAR_PHY_001_030/description
https://data.marine.copernicus.eu/product/GLOBAL_ANALYSISFORECAST_PHY_001_024/description
https://data.marine.copernicus.eu/product/SST_GLO_PHY_L4_NRT_010_043/description
https://help.marine.copernicus.eu/en/collections/4060068-copernicus-marine-toolbox
https://jupyter.org/
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Step 1: Importing the reference libraries. To run the Copernicus Marine Toolbox, you need to import the Copernicus 
Marine Client called copernicus_marine_client (as described in the dedicated page maintained by the Copernicus 
Marine Service Help Desk) and the pprint function, used to print/visualize the retrieved catalogue contents. 

import copernicus_marine_client as copernicusmarine 

from pprint import pprint 

 

Step 2: Retrieve the whole Copernicus Marine Catalogue. This is done by using the function “.describe” given by the 
Copernicus Marine Toolbox. Then, using the function "pprint” you might visualize the metadata associated with 
products as available in the Copernicus Marine Service (this operation can require some time). 

catalogue = copernicusmarine.describe(include_datasets=True) 

pprint(catalogue) 

 

Step 3: Select the desired dataset and print the content. We are interested to access data from the 
cmems_mod_glo_phy_my_0.083-climatology_P1M-m dataset. This can be easily done by using the following 
command: 

catalogue_glo = copernicusmarine.describe(contains=["cmems_mod_glo_phy_my_0.083deg-

climatology_P1M-m"], include_datasets=True) 

 

Again, the “.describe” function opens the Copernicus Marine product catalogue and by using the function “contains” it 
is possible to filter it by selecting only the dataset having keyword “cmems_mod_glo_phy_my_0.083deg-
climatology_P1M-m”. This step can be skipped if you already have sufficient information on product/dataset, variable(s) 
you are interested in. 

Step 4: Launching the subset of the selected dataset in the region of interest. This step is managed by the function 
“.subset” made available by the Copernicus Marine Toolbox. You need to include a list of information, like dataset name, 
variable(s) name(s), bounding box of the region of interest (min/max latitude, min/max longitude), start/end time of 
the period of interest, min/max depth, name of the output file and directory where to find it. In this case, we refer to 
the Pacific Ocean bounding box. 

copernicusmarine.subset( 

  dataset_id="cmems_mod_glo_phy_my_0.083deg-climatology_P1M-m", 

  variables=["thetao"], 

  minimum_longitude=-180, 

  maximum_longitude=180, 

  minimum_latitude=-60, 

  maximum_latitude=60, 

  start_datetime="1993-01-01T00:00:00", 

  end_datetime="2016-12-31T23:59:59", 

  minimum_depth=0, 

  maximum_depth=0.5, 

  output_filename = "CMEMS_Pacific-Ocean_thetao_clim.nc", 

  output_directory = "copernicus-data" 

) 

 

By executing the cell, you will be asked to provide username and password of your Copernicus Marine account: after 
inserting, the download of the file containing the climatological monthly temperature fields given by the GLO-PHY MY 
system. After that, the download of the file will start as shown in Figure 2. Once completed, the output file 
CMEMS_Pacific-Ocean_thetao_clim.nc will be accessible through the local folder copernicus-data and ready to be 
used. 

2.1.2.1. Example on how to download the Copernicus Marine GLO-PHY product from the 
Copernicus Marine Data Store using the GUI 

In this section, we illustrate how to download the monthly mean mixed layer depth field related 01-07/11/2023 directly 
from the Copernicus Marine Data Store by using the GUI, in the Indian Ocean bounding box. 

Step 1: Access to the GLO-PHY NRT system main page from the Copernicus Marine Data Store (hyperlinked in Section 
2.1.1). Visualization of the options for accessing relevant information about the selected product. As shown in Figure 3, 
the GLO-PHY NRT main page provides an overview of the most relevant information related to the Global Ocean Analysis 
and Forecasting System, including the options for accessing the data. 

https://help.marine.copernicus.eu/en/articles/7970514-copernicus-marine-toolbox-installation
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Option 1: by clicking on “Data Access” tab, you will be redirected to a second page that gives the list of available datasets 
with interfaces for downloading associated data (Figure 4):  

• Subset, which is the new function for interactively select total or a portion of the interested region. 

• Files, that returns the data archive structure of the selected dataset. 

• Maps, that returns WMTS file that you might export to use in your dedicated webservice. 

 

Figure 2: Log file and process related to download of climatological monthly temperature fields given by the GLO-PHY MY system as accessed 
through the Copernicus Marine Data Store. 

 

Figure 3: GLO-PHY NRT main page through the Copernicus Marine Service. 
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Figure 4: Option 1 for accessing Copernicus Marine data using a) subset (in orange), b) files (in green) or c) maps (in red). 

Option 2: by clicking on “Explore in MyOcean Pro” tab, you will be redirected to the MyOcean Pro Viewer webpage that 
shows the 2D map of the selected field (Figure 5). The viewer gives the opportunity to: 

• Add any new field as new layer. 

• Download the file by selecting the bounding box and the range of dates. 

• Access to information about the product/dataset, customize the map, save and export for next uses. 

Once the spatio-temporal information for the selected variables is inserted into the GUI, you might launch the download 
of the file. 

 

Figure 5: Option 2 for accessing Copernicus Marine data using the MyOcean Pro Viewer functionalities. 

Additional information on how to access and download Copernicus Marine data are provided in the Copernicus Marine 
E-Learning Material and at the page dedicated to the MarineData4Asia. 

https://marine.copernicus.eu/services/user-learning-services/tutorials
https://marine.copernicus.eu/services/user-learning-services/tutorials
•%09https:/events.marine.copernicus.eu/marinedata4asia-2024#bl-7d0b3f5b-c3a6-4b40-8749-390d707a7040
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2.2. QGIS Software 

2.2.1. Installation of QGIS 

The GIS software used for this training is the QGIS software in its version 3.28-Firenze Long Term Release (last available 
version as accessed on 15/01/2024).  

QGIS is the widely adopted open-source GIS software, supported by the Open Source Geospatial Foundation (OSGeo) 
and available on many Operating Systems like Windows, MacOS, Linux, IOS and Android.  

To install QGIS, follow the instructions at dedicated installation page and download the OSGeo4W Network Installer. 

Then, choose the Express Install and Check QGIS and GDAL boxes before launching the Installation. 

A video explaining the basic steps for downloading and installing QGIS is available at the page dedicated to Copernicus 
MarineData4Asia. 

2.2.2. Installation of the CMEMS-NetCDF plugin and example on how to load a NetCDF file 

The Copernicus Marine Service makes available the CMEMS-NetCDF plugin, which enables the handling of data in 
NetCDF format. The user can follow the instructions on how to install it in QGIS by accessing the dedicated webpage 
prepared by the Copernicus Marine Team at the E-Learning section, which makes available: 

• The link to download the plugin and 

• The user manual, 

together with some tutorial on how to use it. 

To install the CMEMS-NetCDF plugin, from the top menu of QGIS select Plugins > Manage and Install Plugins…. Then, a 
window Plugin | Install from ZIP appears, and the user can browse through her/his personal folder to select the zip file 
containing the CMEMS-NetCDF plugin as downloaded from the Copernicus Marine E-Learning Section (link in Appendix). 
Finally, select Install Plugin. Figure 6 visualizes the main steps performed though the GUI. The same steps can be 
performed in case an update of the plugin through a new zip file needs to be done. Once installed/updated, the CMEMS-
NetCDF icon appears in the QGIS toolbar and it is ready to be used. 

 

Figure 6: Steps for installing / updating a the CMEMS-NetCDF plugin.  

Once clicking on the CMEMS-NetCDF icon available in the toolbar or selecting Plugins > NetCDF2GIS > Import NetCDF 
files from the QGIS top menu, a GUI appears with functions to load and explore the NetCDF file structure and semantic, 
as schematized in Figure 7. 

https://docs.qgis.org/3.28/en/docs/index.html
https://docs.qgis.org/3.28/en/docs/index.html
https://qgis.org/fr/site/forusers/download.html
https://qgis.org/en/site/forusers/alldownloads.html#osgeo4w-installer
https://marine.copernicus.eu/services/user-learning-services/qgis-plugin-cmems-netcdf
https://marine.copernicus.eu/services/user-learning-services/qgis-plugin-cmems-netcdf
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Figure 7: Overview of the CMEMS-NetCDF plugin GUI. 

2.2.3. Installation of the QuickMapServices plugin 

The QuickMapService is developed by NextGIS and allows to easily add basemaps and geoservices. Details are given in 
the dedicated QGIS plugins page. 

To install it, open the QGIS software and click on Plugins > Manage and install Plugins in the top menu. In the search 
bar, type “QuickMapService” and the window will be refreshed once the plugin is selected as in Figure 8. Click on “Install 
Plugin” (or “Reinstall Plugin” to refresh it). 

 

Figure 8: The QuickMapService plugin. 

2.2.4. Installation of the DataPloty plugin 

DataPloty is a Python-based plugin that allows the creation of D3 like plots thanks to the Plotly library and the Python 
API. It has been developed by Faunalia. Details are given in the dedicated QGIS plugins page. 

https://plugins.qgis.org/plugins/quick_map_services/
https://www.faunalia.eu/it/dev/dataplotly
https://plugins.qgis.org/plugins/DataPlotly/#plugin-details
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To install it, open the QGIS software and click on Plugins > Manage and install Plugins in the top menu. In the search 
bar, type “DataPloty” and the window will be refreshed once the plugin is selected as in Figure 9. Click on “Install Plugin” 
(or “Reinstall Plugin” to refresh it). 

 

Figure 9: DataPloty plugin. 
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3. Launching a QGIS project and importing a basemap 

This section opens with some basic instructions on how to create a new project – that will be used during the training 
session – and play with the available basemaps for supporting the visualization & analysis of the Copernicus Marine 
data. 

3.1. Open QGIS and create a new empty project 

On the top menu, click on Project > New to create a new project (Figure 10). 

 

Figure 10: Launching a new project on QGIS. 

Finally, save the project by selecting, in the top menu, Project > Save as > <name>.prj in a dedicated folder in your 
computer. 

3.2. Overview of installed plugins access and configuration of a basemap 
through QuickMapServices 

Pre-installed plugins –QuickMapServices, DataPloty, CMEMS-NetCDF  – can be invoked by clicking on Plugins in the top 
menu or directly clicking on the corresponding icons, as schematically shown in Figure 11. 

 

Figure 11: Options for invoking plugins: a) through top menu “Plugins” command or b) through specific icons. 

The QuickMapServices is configured to help the user to easily geolocate any specific area. By clicking the corresponding 
icon in the toolbar, the user can select the preferred basemap on a pre-loaded list. In this training, we will use the 
Google Hybrid map. Once loaded, a map like the one in Figure 12 is displayed on QGIS map canvas and ready to be used 
for next steps. 

The DataPloty is here used to plot timeseries or scatter plots for given set of ocean variables, to support monitoring and 
validation activities. 

The CMEMS-NetCDF plugin is, finally, used for opening and loading the NetCDF files related to Copernicus Marine 
products as described in Section 2.1.1.  

Application of DataPloty and CMEMS-NetCDF plugins will be given in the next chapter. 
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Figure 12: Google basemap imported in QGIS. 
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4. Loading the Copernicus Marine Products 

This section illustrates the steps for loading and visualizing one of the Copernicus Marine Products, whose detailed list 
is given in Section 2.1.1, using the CMEMS-NetCDF plugin. We will show how to open and visualize the mixed layer 
depth in the Indian Ocean: 

• cmems_mod_glo_phy_anfc_0.083deg_P1D-m_MLD-20231101-20221107.nc 

This example is described with the purpose to give to the reader a general overview on how to deal with files 
characterized by 2D (and applicable to 3D data as well), with variables that depend on time (and that can be used for 
an animation).  

It is important that at this step the reader has pre-installed the CMEMS-NetCDF plugin, as described in Section 2.2.2. 

4.1. Steps for loading and display the mixed layer depth file 

The objective of this section is to illustrate how to load and display the mixed layer depth file from GLO-PHY NRT 
cmems_mod_glo_phy_anfc_0.083deg_P1D-m_MLD-20231101-20221107.nc using the CMEMS-NetCDF plugin.  

A representation of the workflow is given in Figure 13. 

Step 1: clicking on “+”, you may load the file you are interested in. Automatically, this function opens a window where 
you may browse in your local archive for selecting the NetCDF file. 

Step 2: on the right side of the CMEMS-NetCDF application window, you will see the list of loaded metadata from the 
selected file. By doing a right click on the selected variable (in this case, the mlotst variable related to the mixed layer 
depth), a menu will appear with option to select “Add Layers” or “Sequence Layers”. 

Step 3: by selecting “Add Layers”, the application opens a new window with details on the selected variable. Here, you 
may select the timestamp (and depth if available, but here not shown) and finally add to your QGIS project. 

 

Figure 13: Steps to load the mixed layer depth file using CMEMS-NetCDF plugin. 

Once the file has been loaded and the layer has been added, the mixed layer depth field will be displayed on QGIS map 
canvas. The workflow to customize the map is shown in Figure 14, while the final result is shown in Figure 15. 

Step 1: the active layer “mlotst_01112023_0000” is displayed in QGIS after loading the NetCDF file through the CMEMS-
NetCDF plugin. It is shown with default colormap. 

Step 2: to customize it, do right click to visualize the right menu, with list of functions to modify the active layer. 

Step 3: select “Properties”. 
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Step 4: after selecting, the menu as shown in the figure is displayed. You may modify the colormap, min/max values for 
the mixed layer depth and number of intervals for color distribution as you prefer. 

 

Figure 14: Overview of the loaded map and access to layer properties. 

 

 

Figure 15: Final visualization of the map, after customizing layer properties. 
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5. Technical notes about specific QGIS functions used during 
the training session 

This section aims at providing some technical notes about used QGIS functions and plugins for performing the 
MarineData4Asia Training session. Demonstrative application is provided in the dedicated video. 

5.1. Calculating SST anomalies to monitor El Niño event  

In this exercise, we will illustrate how to use QGIS functionalities to easily monitor El Niño event evolution from Jun to 
Nov 2023 in the Pacific Ocean. The following steps will be described in detail in the next subsections: 

• Loading upstream data in QGIS using CMEMS-NetCDF plugin. 

• Calculating SST anomalies in the period Jun-Nov 2023 using Graphical Calculator. 

• Characterization of the Niño3.4 region along the reference period by clipping the results at Niño3.4 bounding 
box. 

5.1.1. Loading input data 

To load the input data, we use the CMEMS-NetCDF QGIS plugin. Once the plugin is launched, it is sufficient to perform 
sequentially the following commands: 

• Load climatological “thetao” variable from GLO-PHY MY sytem: 
o Step 1: from the GUI, “Add a NetCDF file” and select the file related to 

GLOBAL_MULTIYEAR_PHY_001_030 climatological dataset from your local disk (see Section 2.1.1 for 
the file specifications). 

o Step 2:  from the Variables menu, select “thetao” variable by doing right click on one of it and selecting 
“Add layer”. Then, a window pops-up.  

o Step 3: select the fields corresponding to the period from Jun to Nov at 0.49 m of depth. In “Group”, 
give the name of the new group, for instance “thetao_clim”, and add the selected variable. 

• Load monthly mean “theato” variable from GLO-PHY NRT system: 
o Step 4: from the GUI, “Add a NetCDF file” and select the file related to 

GLOBAL_ANALYSISFORECAST_PHY_001_024 monthly mean dataset from your local disk (see Section 
2.1.1 for the file specifications). 

o Step 5: from the Variables menu, select “thetao” variable by doing right click on one of it and selecting 
“Add layer”. Then, a window pops-up. 

o Step 6: select the fields corresponding to the period Jun to Nov 2023 at 0.49 m of depth. In “Group”, 
give the name of the new group, for instance “thetao_nrt”, and add the selected variable. 

Steps are schematized in Figure 16. The results – how the maps are visualized in the QGIS map viewer – is shown in 
Figure 17. 

5.1.2. Calculating SST anomalies 

The SST anomaly at month M is given as difference between the SST monthly mean and the corresponding SST monthly 
climatology at reference month M. To calculate SST anomaly, we use the Graphical Modeler. As reported in the QGIS 
documentation1, the Graphical Modeler allows you to create complex models using a simple and easy-to-use interface.  

In the following, steps for configuring the Graphical Modeler are described: 

Step 1: launch of the Graphical Modeler. The Graphical Modeler is accessed through Processing > Graphical Modeler 
(from the QGIS top menu).  

Step 2: setup of the Graphical Modeler. Once launched, the Graphical Modeler window appears. We need to configure 
then the data model for performing the calculation, which consists on using 2 “Raster Layers” (accessible through 
“Input” tab), a “Raster Calculator” (accessible through “Algorithms” tab). The “Raster Calculator” requires and 
Expression to be set up: 

"sst_nrt@1" - "sst_clim@1" 

And the specification of the output raster – that we call “ssta”. An overview of the workflow is shown in Figure 18. 

 

1 https://docs.qgis.org/3.28/en/docs/user_manual/processing/modeler.html  

https://docs.qgis.org/3.28/en/docs/user_manual/processing/modeler.html
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Figure 16: Loading input data. 

 

Figure 17: Visualization of loaded maps in QGIS. 

Step 3: Graphical Modeler run. Once the Graphical Modeler is launched (Step 8 in Figure 18), a new window is opened, 
that links to the last phase of computation. By running in batch mode, you may load the input fields belonging to each 
group – monthly means from GLO-PHY NRT system “sst_nrt”, monthly climatology from GLO-PHY MY system “sst_clim”. 
An overview of the steps is given in Figure 19. After running the process, we can visualize the result as in Figure 20. 
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Figure 18: Steps for setting the Graphical Modeler for the calculation of SST anomalies. 

 

Figure 19: Steps for running the model implemented in the Graphical Modeler as batch process. 

 

Figure 20: Visualization of SST anomalies maps, computed for the period Jun-Nov 2023 (here, the Nov 2023 is displayed). 
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5.1.3. Characterization of Niño3.4 region 

Niño3.4 bounding box is defined as follows: 170°W → 170°E; 5°S → 5°N: it is drawn in the map(s) by adding it a new 
layer. By following the next steps, you will be able to add a new layer in the main QGIS project. 

Step 1: create a new shapefile. Select Layer > Create Layer > New Shapefile Layer from the QGIS menu. Then, a window 
for specifying which type of layer you want to create is opened.  

Step 2: setup of the new layer. 

• As “File name”, gives a name to the new shapefile, for example “nino3.4_bb.shp” (browing in your local 
computer). 

• As “Geometry type”, select “Polygon”. 

• Select “OK”. 

Step 3: The new “nino34_bb” is visualized as layer.  

• Select “Toggle editing” icon. 

• Select “Add polygon feature” icon. 

• Draw the polygon related to the region of interest directly in the map. 

• To improve the accuracy of the bounding box coordinates, select “Vertex tool”. 

• Once activated, you can edit directly through the map the coordinates of the bounding box of the defined 
region, by giving the coordinates of the Niño3.4 bounding box. 

• Once done, de-select the “Toggle Editing”. In this way, you save the shape of your polygon. 

• The result of this list of commands is shown in Figure 21. 

 

Figure 21: Specification of Niñ03.4 region as polygon shapefile (purple box). 

Step 4: clipping the SST anomaly layers into the Niñ03.4 bounding box. 

• Select Raster > Extraction > Clip by mask layer from the QGIS top menu. 

• From the opened window, select Run as batch process. 

• In the given window, specify: 
o As “Input layer”: the SST anomaly layers previously computed. 
o As “Mask layer”: the Niño3.4 region (nino34_bb) previously defined. 
o As “Clipped (mask)”: after specifying the root “nino34_” (as example), select the autofill function 

based on the input filename. In this way, QGIS will compose the final filename by adding to the input 
layer the prefix “nino34_”. 

o Select “Load layers on completation” in order to visualize the output layers directly in the QGIS map 
viewer. 

o Run “OK”. 

• The result is shown in . 
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Figure 22: Extraction of SST anomaly values at Niño3.4 region using clipping function. 

Step 5: calculation of basic metrics. In the Niño3.4 region, we can calculate the basic metrics – mean, maximum and 
minimum values, variance, for instance – by using the “Zonal Statistics” tool. 

• Go to Processing > Toolbox from QGIS top menu. A box will be automatically opened, then type “Zonal 
Statistics” and select I by doing double click. 

• Select the “Run as batch process”. 

• Specify: 
o Input layer: the Niño3.4 bounding box layer. 
o Raster layer: the SST anomaly fields layers previously computed on Niño3.4 region. 
o Statistics to calculate: for example, mean, maximum, minimum and variance. 
o Zonal statistics: here you specify the name of the output layers. Select a keyword to be used as root 

of the filename – for example, “stats_” – and then ask to QGIS to autofill the name of the layer by 
using the “Raster layer” filenames. 

o Run the process. 

The workflow showing the steps are also reproduced in Figure 23. 

 

Figure 23: Steps for performing the calculation of metrics using Zonal Statistics tool. 

After completing steps for performing the calculation of metrics using Zonal Statistics tool, QGIS returns new layers as 
highlighted with the blue box in Figure 24. To have a more comprehensive overview of metrics, we can operate a 
merging of the given statistical layers: 
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• Go to Vector > Data Management Tools > Merge vector layers from the QGIS top menu. 

• Specify: 
o Input layers: the layers per months containing computed metrics. 
o Merged: the name of the final layer (i.e., nino34_stats). 
o Press “Run”. 

After this list of commands, you will visualize the merged layer “nino34_stats” among the active layers. By opening the 
table of attributes, you will visualize the overall metrics, computed per each month for which we have the SST 
anomalies. A recap of the steps is displayed in 

 

Figure 24: (in blue) List of layers referring to statistics. Inspection of one of the layers containing through its table of attributes. 

 

Figure 25: Steps for performing the merging of the layers containing statistics. The final result is available by inspecting the output layer’s table 
of attributes (shown in step 5, with orange box). 

To plot the timeseries of mean SST anomaly in the Niño3.4 region, we can use the DataPloty plugin. 

Step 1: select the DataPloty tool from the list of available plugins, or by clicking at the corresponding icon (as shown in 
Section 3.2). 

Step 2:  

• In “Plot type”, select “Scatter plot” 
o Input layer: the layer containing statistics (i.e., “nino34_stats”). 
o Fied subset: as X field, specify “layer”; as Y field, specify for instance “_mean”. 
o (customize colors as you prefer, here we keep the default settings). 

• In “Layout Options”: 
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o Plot title: “Mean SST anomalies in Niño 3.4 region in the period Jun-Nov 2023”. 
o X label: “layer (with ref. to time)”. 
o Y label: “SST anomaly (Celsius)". 

• Press "Create Plot". 

A summary of the steps is shown in Figure 26. 

 

Figure 26: Steps for creating plot of mean SST anomalies in Jun-Nov 2023 using DataPloty. The final graph (in orange box) can be exported as 
JPEG or HTML. 

 A zoom of the plot is shown in Figure 27: the graph (from QGIS or in HTML) is interactive, so you may visualize the value 
of the selected point from the tooltip (in the example, it is shown the value of the SST anomaly in Sep 2023). 

 

Figure 27: Timeseries of SST anomalies in the Niño3.4 region in the period Jun-Nov 2023. 

5.2. Extracting values of SST, SSS and MLD in the Gulf of Bengal 

In this exercise, we will illustrate how to use QGIS functionalities to extract Essential Ocean Variables (EOV) values (i.e., 
SST, SSS and MLD) by: 

• Loading upstream data in QGIS using CMEMS-NetCDF plugin. 

• Defining the points where EOV will be extracted. 

• Extracting EOV values from the Copernicus Marine products at selected locations. 
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• Evaluating SST in the Gulf of Bengal in the period 01-07/11/2023. 

The target region is the Indian Ocean, with focus to the Gulf of Bengal. 

5.2.1. Loading input data 

In this exercise, we will use the daily means of SST, SSS and MLD as given by the GLO-PHY NRT system for the period 01-
07/11/2023 (only one week, as example), and the SST daily satellite field as provided by the SST-TAC (details on products 
and datasets are given in Section 2.1.1). Steps for loading such files have been already introduced in the previous 
exercise (Section 5.1.1). Here, we show only some screenshot of the fields as displayed in QGIS, after customization of 
the palette: 

• SST field from GLO-PHY NRT system on 01/11/2023 expressed in Celsius in Figure 28. 

• SSS field from GLO-PHY NRT system on 01/11/2023 expressed in PSU in Figure 29. 

• MLD field from GLO-PHY NRT system on 01/11/2023 expressed in m in Figure 30. 

• SST satellite field from SST-TAC on 01/11/2023 expressed in Kelvin in Figure 31. 

 

Figure 28: SST from GLO-PHY NRT system (01/11/2023). 

 

Figure 29: SSS from GLO-PHY NRT system (01/11/2023). 

5.2.2. Definition of the locations for the extraction of the EOV values 

To specify which are the locations of interest to be monitored and for which we would like to retrieve the Copernicus 
Marine data, we need first to create a layer containing the coordinates of such points. 

Step 1: creation of layer of points.  

• Go to Layer > Create Layer > New Shapefile Layer from QGIS top menu. 

• At the opening of the dedicated window, specify: 
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o File name: “points.shp” (to be saved in your local computer, so select the full path). 
o Geometry type: in this case it is “Points”. 
o Press “OK”. 

Step 2: definition of points to monitor in the Indian Ocean region. 

• Select the layer named “points”. 

• Select “Toggle Editing” icon to activate “points” layer modification. 

• Select “Add Point Features” icon to activate the possibility to set points in the map. 

• Draw points in location you prefer (in this example, we select 4 points close to Maldives, Port of Colombo in Sri 
Lanka, area of influence of Gange River in the Gulf of Bengal, Singapore, respectively. 

• Once digitized, you can customize the “points” layer, including modification of the attributes table for including 
an extra field, called “location” (as text) where you may include the name of the location to easily identify it. 

The view of selected points is given in Figure 32. At this step, there is no geolocalization of the selected points (that will 
be then completed in the next phase). 

 

Figure 30: MLD from GLO-PHY NRT system (01/11/2023). 

 

Figure 31: SST satellite observation (01/11/2023). 
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Figure 32: Visualization of points in the Indian Ocean where to extract EOV values from the Copernicus Marine products. 

5.2.3. Extraction of EOV at selected points  

To perform the extraction of the scalar values provided by the Copernicus Marine products in the points of interest, we 
use the tool called “Sample raster values”, accessible through the Processing Toolbox. Once launched, the “Sample 
raster values” can be run in standalone or as batch process. Here, we propose to use as batch process in order to make 
a more comprehensive extraction of the values.  

Once the “Run as Batch Process” is selected, a new window will open and it requires: 

• Input layer: the layer “points” that specifies the location of interest. 

• Raster layer: the list of active layers containing the Copernicus Marine information for SST, SSS and MLD as 
given by the GLO-PHY NRT system. 

• Sampled: here is where we specify the name of the layers containing the sampled information. We specify a 
tag (i.e., “sample_”) and the function autocompletes the layer name by adding an extra fieldname from the 
Raster layer. 

• Be sure to have “Load layer on completion” active before running. 

• Press “OK”. 

After running the process, expected layers will appear in the QGIS Layers board as shown in Figure 33 (in this example, 
we have 3 main samples related to SST, SSS, MLD on 01/11/2023). Selecting one of these layers and opening the 
“Attribute Table”, you will be able to see the corresponding EOV values at each location (in Figure 33 we are displaying 
the SST values, but similarly can be done for SSS and MLD). 

Regarding SST observations from satellite, it is needed to convert original values, expressed in Kelvin, to new ones, 
expressed in Celsius. To do this, it is sufficient to implement a Graphical Modeler that will be in charge of units 
conversion: 

• Go to Processing > Graphical Modeler from the QGIS top menu. 

• Once the Model Designer window is open, you may consider: 
o Inputs: a “Raster layer”, that will represent the SST expressed in Kelvin. It is called generically “sst”. 
o Algorithm: you may select the “Raster Calculator”, that needs to be instructed to implement the 

formula for the conversion Kelvin to Celsius, by doing the following: 
▪ Expression: "sst@1" - 273.15 
▪ Using model input: sst 
▪ Output: sst_celsius 

o At this point, you will display the workflow. 
o Run the “Run model” icon. 

• Once this is run, a new window “Model” is displayed. 

• Go to “Run as Batch Process”. 

• Once this is run, a new window “Batch Processing – model” is displayed. Give the following specification: 
o sst field: it needs to be instructed to open the layers that need to be converted from Kelvin to Celsius. 
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o sst_celsius field: it will contain the name of the output layer (for example, using the tag “celsius_” and 
letting the modeler to autofill the name with the name of the SST layer). 

o Check “Load layers on completation”. 
o Lauch “Run”. 

At the end of this step, you will see the new layers containing SST satellite observations expressed in Celsius that can be 
used in the next steps. 

5.2.4. Evaluation of SST in the Bay of Bengal 

QGIS can be extremely powerful for analysing correlations between model and observational values. In this example, 
we will see how to extract SST values from GLO-PHY NRT system and from satellite in the Gulf of Bengal by using a grid 
of 0.5° resolution.  

Step 1: creation of a grid in the region of interest.  

• Go to Processing > Toolbox from the QGIS top menu and search for “Create grid”. 

• Once selected, a window will appear where you need to specify the following information: 
o Grid type: Rectangle (Polygon). 
o Grid extent: here we give the bounding box of the Bay of Bengal that is 79°E → 96°E; 7°N →20°N. 
o Horizontal spacing: 0.5 (given in degrees). 
o Vertical spacing: 0.5 (given in degrees). 
o Grid: indicate where the new layer will be saved and how it is called (in this example, it will be saved 

locally as “grid.shp”). 
o Run “OK”. Then, at this point the grid is created. 

• Go to Vector > Geometry Tools > Centroids from the QGIS top menu. 

• Once selected, a window will appear where you need to specify the following information: 
o Input layer: the “grid” shapefile as previously computed. 
o Centroids: indicate where the new layer will be saved and how it is called (in this example, it will be 

saved locally as “grid_centroids.shp”). 
o Run “OK”. Then, the distribution of centroids will be displayed in the map. 

• Go to Layer > Create Layer > New Shapefile Layer from the QGIS top menu. The scope here is to define in 
which region we would like to extract SST information. 

• Once selected, a window will appear where you need to specify the following information: 
o File name: indicate where the new layer will be saved and how it is called (in this example, it will be 

saved locally as “region.shp”). 
o Geometry type: Polygon. 
o Run “OK”.  

• In the map, you may now activate the new layer “region” in “Toggle Editing” mode and start digitizing the 
region of interest. 

At the end of this sequence of commands, you will display on QGIS map viewer something like what shown in Figure 
35. 

Step 2: processing the grid to work on the region of interest. 

• Go to Processing > Toolbars > Clip by mask layer from the QGIS top menu. 

• Once selected, a window will appear, where you need to specify the following information: 
o Input layer: here you give the shapefile containing the grid centroids (“grid_centroids”). 
o Mask layer: here you give the shapefile containing the region of interest (“region”). 
o Clipped (mask): indicate here where the new layer will be saved and how it is called (in this example, 

it will be saved locally as “grid_centroids_clip.shp”). 
o Run “OK”. 

At the end of this sequence of commands, displayed in Figure 34, you will display on QGIS map viewer the centroids 
clipped into the region of interest. In such points, we are going to extract SST from model and observations. The final 
shape of the points where we are going to extract the information is shown in Figure 35. 
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Figure 33: Steps for extracting SST, SSS and MLD values on 01/11/2023 for the 4 selected locations from the GLO-PHY NRT product. 

 

Figure 34: Steps for clipping grid centroids in the region of interest. 
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Figure 35: Generation of grid centroids (green dots) and region of interest (red polygon) in the Bay of Bengal. 

Step 3: extract Copernicus data in the Bay of Bengal using the selected grid. 

• Go to Processing > Toolbars > Add raster values to points from the QGIS top menu.  

• Once selected, a window will appear. Select the batch mode processing and specify the following information: 
o Points: here you give the shapefile containing centroids in the region of interest 

(“grid_centroids_clip”). 
o Grids: from the open layers, here you select the layers related to SST from GLO-PHY NRT and from 

satellite observations. 
o Result: indicate here where the new layer will be saved and how it is called (in this example, it will be 

saved locally as “points_SST.shp”). 

At the end of this sequence of commands, summarized also in Figure 36, you will display a new layer that contains 
numerical results from the extraction of SST values from GLO-PHY NRT and from satellite observations after converting 
from Kelvin to Celsius (Section 5.2.3). By accessing the “Attribute Table”, you will display the daily SST values given by 
the 2 source of products over the week 01-07/11. A screenshot of the table containing the extracted data is shown in 
Figure 37. 

 

Figure 36: Steps for extracting SST data at given grid points. 
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Figure 37: SST values from GLO-PHY NRT system and from satellite observations interpolated at the same grid for the Bay of Bengal. 

From the shapefile containing the SST values in the period of interest and represented in Figure 37, it is then possible 
to perform any additional manipulation. As example, we can create a scatter plot for day 01/11/2023 of SST values using 
DataPloty, as shown in Figure 38. 

 

Figure 38: Scatter plot for SST values on 20231101. 
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Conclusions  

This report focused on presenting the way we can use the Blue Ocean products provided by the Copernicus Marine 
Service in QGIS for monitoring El Niño events in the tropical Pacific Ocean and key areas in the Indian Ocean and Bay of 
Bengal.  
The document is divided in 3 main parts:  

• The first part gave an overview of the study area and the description of the Copernicus Marine products 
specifically used in the demonstrative phase: the Global Ocean Physics Reanalysis system, Global Ocean Physics 
Analysis and Forecasting system, the Global SST L4 satellite observations.  

• The second part described the QGIS software, focusing particularly on the used plugins: the CMEMS-NetCDF 
plugin for loading, reading and processing the NetCDF files provided by the Copernicus Marine Service; the 
QuickMapServices for loading basemap used as background of the ocean fields, to improve readability of 
geographical information. Examples on how to use them are provided; DataPloty, for plotting charts and 
timeseries of EOV in specific points/regions.. 

• The third part showed the main technical implementations discussed also during the training session, providing 
to users an overview of the main functions and tools used for tracking the Jun-Nov 2023 El Niño event occurring 
in the tropical Pacific Ocean. It is presented how to run a batch process for computing SST anomalies data, how 
specify points where to visualize timeseries of EOV in the Indian Ocean and, finally, how to automatically 
interpolate Global Ocean data (both from forecasting system and from satellite observations) in the Bay of 
Bengal for supporting validation of model results. 

These technical notes complemented the training session given during the MarineData4Asia Event, organized by 
Mercator Ocean International for the Copernicus Marine Service on 25-26/11/2023. 
 
Please, visit the dedicated User Learning Service promoted by the Copernicus Marine Service to access the e-learning 
material and discover other interesting exercises. 
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Useful links: 
 

QGIS: https://docs.qgis.org/3.28/en/docs/index.html 
 
Copernicus Marine Service: https://marine.copernicus.eu/ 
 
Copernicus Marine E-Learning Material: https://marine.copernicus.eu/services/user-learning-
services/tutorials 
 
Copernicus Marine QGIS plugin installation: https://marine.copernicus.eu/services/user-learning-
services/qgis-plugin-cmems-netcdf  
 
Copernicus Marine Toolbox: https://help.marine.copernicus.eu/en/articles/7970514-copernicus-marine-
toolbox-installation 
 
Copernicus Marine YouTube Channel: https://www.youtube.com/@copernicusmarineservice1453 
 
Copernicus Webinar - MarineData4Asia: 

• https://events.marine.copernicus.eu/marinedata4asia-2024#bl-7d0b3f5b-c3a6-4b40-8749-
390d707a7040 

• https://marine.copernicus.eu/events/webinar-marine-data-4-asia  
 
CF Conventions: https://cfconventions.org/ 
 
NetCDF: https://www.unidata.ucar.edu/software/netcdf/  
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