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1. Introduction 

1.1. Scope of the document 

MarineData4SouthAmerica training event, promoted by Mercator Ocean International in the framework of the 
Copernicus Marine Service, aims at increasing user uptake and awareness in the South America region: to achieve this 
target, the training event shows how to use technologies such as QGIS to delve into some of the main coastal and 
oceanographic phenomena in the region and showcase local studies using the Copernicus Marine products. 

In this tutorial, we will learn how to: 

• Visualize the Copernicus Marine products in the Western Tropical Atlantic, extracting Essential Ocean Variables 
(EOV) values in same specific locations. 

• Perform a geospatial analysis of physical and biogeochemical conditions in the Amazon River plume region and 
in its delta. 

Technical material here described is complementary to the tutorial videos available on the Copernicus Marine Service 
YouTube page. 

1.2. Focusing on the Amazon River and how coastal circulation influences its 
plume 

The Amazon River is the largest river in South America and in the world, responsible for approximatively 16% of the 
global freshwater discharge. It transports a large amount of organic material, sediment and dissolved substances that 
impact on the biological community structure of the North Brazil Continental Shelf, as described in Gouveia et al. (2019). 
Its plume feeds into the Northwestern Tropical Atlantic and is influenced by an energetic system of coastal currents: the 
mean surface circulation is dominated by the strong western boundary North Brazil Current (NBC) that flows north-
westerly along the Brazilian coast, and the Guyana Current (GC). A component of the NBC retroflects after crossing the 
Equator and flows eastward with the North Equatorial Contercurrent (NECC) (Gouveia et al., 2019). 

Freshwater inputs into the open ocean modify the local sea surface salinity (SSS) and therefore the buoyancy and vertical 
stratification of the surface layers, ad discussed in Fournier et al. (2015): for this reason, it is important to assess the 
spatial extension of the plume for a better understanding of the physical and biogeochemical conditions in the coastal 
zone. Today availability of model products and high-resolution satellite data help in better assessing the temporal 
evolution and spatial distribution of SSS and chlorophyll especially in complex regions like the Amazon River Delta. 

The scope of this training session is to offer a first set of technical tools, based on QGIS, for understanding the physical 
conditions of the Amazon River plume and the coastal processes occurring in its delta. An overview of the study area in 
given in Figure 1.  

 

Figure 1: Application area considered during the MarineData4SouthAmerica Copernicus Marine Training Session. 

https://www.youtube.com/@copernicusmarineservice1453/videos
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2. Copernicus Marine Service Products, contextual 
information, and GIS tool 

2.1. Copernicus Marine Service products  

2.1.1. List of used products, datasets and files 

In this training on MarineData4SouthAmerica, we will focus on the Western Tropical Atlantic region to characterize 
the Amazon River plume evolution and impact on coastal circulation. The study area is characterized by the following 
bounding box: 

• Western Tropical Atlantic: 70°W to 30°W; 5°S to 20°N. 

In the following, the list of Copernicus Marine products downloaded from the Copernicus Marine Data Store and used 
in this tutorial. 

• GLOBAL_ANALYSISFORECAST_PHY_001_024, which is the Global Ocean Physics Analysis and Forecast system 
(GLO-PHY NRT). We select the following datasets: 

o Dataset: cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m 
▪ File: cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2023.nc, related to Jun 2023 

monthly salinity (so). 
▪ File: cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2021.nc, related to Jun 2021 

monthly salinity (so). 
o Dataset: cmems_mod_glo_phy-cur_anfc_0.083deg_P1M-m 
o File: cmems_mod_glo_phy-cur_anfc_0.083deg_P1M-m_Jun-2023.nc, related to Jun 2023 monthly 

currents (uo, vo). 

• GLOBAL_ANALYSISFORECAST_BGC_001_028, which is the Global Ocean Biogeochemistry Analysis and 
Forecast system (GLO-BGC NRT). We select the following dataset: 

o Dataset: cmems_mod_glo_bgc-pft_anfc_0.25deg_P1M-m 
▪ File: cmems_mod_glo_bgc-pft_anfc_0.25deg_P1M-m_Jun-2023.nc, related to chlorophyll 

(chl) and phytoplankton (phyc) concentrations in Jun 2023. 
o Dataset: cmems_mod_glo_bgc-bio_anfc_0.25deg_P1M-m 

▪ File: cmems_mod_glo_bgc-bio_anfc_0.25deg_P1M-m_Jun-2023.nc, related to dissolved 
oxygen (o2) in Jun 2023. 

• OCEANCOLOUR_GLO_BGC_L4_NRT_009_102, which is the Global Ocean Colour L4 (monthly and interpolated) 
from Satellite Observations NRT product (GLO-OC-SAT NRT). We select the following dataset: 

o Dataset: cmems_obs-oc_glo_bgc-plankton_nrt_l4-olci-300m_P1M 
▪ File: cmems_obs-oc_glo_bgc-plankton_nrt_l4-olci-300m_P1M_Jun-2023.nc, related to Jun 

2023 monthly chlorophyll (CHL). 

• OCEANCOLOUR_GLO_BGC_L4_MY_009_104, which is the Global Ocean Colour L4 (monthly and interpolated) 
from Satellite Observations (1997-ongoing) (GLO-OC-SAT MY). We select the following dataset: 

o Dataset: cmems_obs-oc_glo_bgc-plankton_my_l4-olci-4km_P1M 
▪ File: cmems_obs-oc_glo_bgc-plankton_my_l4-olci-4km_P1M_Jun-2021.nc, related to Jun 

2021 monthly chlorophyll. 
▪ File: cmems_obs-oc_glo_bgc-plankton_my_l4-olci-4km_P1M_Jun-2023.nc, related to Jun 

2023 monthly chlorophyll. 
o Dataset: cmems_obs-oc_glo_bgc-plankton_my_l4-olci-300m_P1M 

▪ File: cmems_obs-oc_glo_bgc-plankton_my_l4-olci-300m_P1M_Jun-2021.nc, related to high 
resolution Jun 2021 monthly chlorophyll. 

▪ File: cmems_obs-oc_glo_bgc-plankton_my_l4-olci-300m_P1M_Jun-2023.nc, related to high 
resolution Jun 2023 monthly chlorophyll. 

2.1.2. How to download data from the Copernicus Marine Service? 

Here, we will shortly demonstrate the steps to download the Global Model data listed in Section 2.1.1 from the 
Copernicus Marine Service, using the new recent tools provided by the Service: the Copernicus Marine Toolbox and the 
function subset available directly in the Copernicus Marine Data Store.  

https://data.marine.copernicus.eu/product/GLOBAL_ANALYSISFORECAST_PHY_001_024/description
https://data.marine.copernicus.eu/product/GLOBAL_ANALYSISFORECAST_BGC_001_028/description
https://data.marine.copernicus.eu/product/OCEANCOLOUR_GLO_BGC_L4_NRT_009_102/description
https://data.marine.copernicus.eu/product/OCEANCOLOUR_GLO_BGC_L4_MY_009_104/description
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2.1.2.1. Example on how to use the Copernicus Marine Toolbox 

The Copernicus Marine Toolbox is the new client that will be used to explore and download the Copernicus Marine data. 
In the reference link, a detailed description of the steps to install and run it is given; additional details are provided at 
the Jupyter Notebook video-tutorial given during this MarineData4SouthAmerica Training session. In this section, we 
only illustrate the basic commands run through a Jupiter Notebook for downloading GLO-PHY NRT data as described in 
Section 2.1.1. 

For running this example, you first need to install and configure the Copernicus Marine Toolbox in your local machine. 
Once done, you might simply follow these basic steps for getting the “cmems_mod_glo_phy-so_anfc_0.083deg_P1M-
m_Jun-2023.nc” file, related to monthly averaged salinity for Jun 2023, from the Copernicus Marine Data Store. 

Step 1: Importing the reference libraries. To run the Copernicus Marine Toolbox, you need to import the Copernicus 
Marine Client called copernicus_marine_client (as described in the dedicated page maintained by the Copernicus 
Marine Service Help Desk) and the pprint function, used to print/visualize the retrieved catalogue contents. 

import copernicus_marine_client as copernicusmarine 

from pprint import pprint 

 

Step 2: Retrieve the whole Copernicus Marine Catalogue. This is done by using the function “.describe” given by the 
Copernicus Marine Client. Then, using the function "pprint” you might visualize the metadata associated with products 
as available in the Copernicus Marine Service (this operation can require some time). 

catalogue = copernicusmarine.describe(include_datasets=True) 

pprint(catalogue) 

 

Step 3: Select the desired dataset and print the content. We are interested to access data from the 
cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m dataset. This can be easily done by using the following command: 

catalogue_glo = copernicusmarine.describe(contains=["cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m"], 

include_datasets=True) 

 

Again, the “.describe” function opens the Copernicus Marine product catalogue and by using the function “contains” it 
is possible to filter it by selecting only the dataset having keyword “cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m”. 
This step can be skipped if you already have sufficient information on product/dataset, variable(s) you are interested 
in. 

Step 4: Launching the subset of the selected dataset in the region of interest. This step is managed by the function 
“.subset” made available by the Copernicus Marine Client. You need to include a list of information, like dataset name, 
variable(s) name(s), bounding box of the region of interest (min/max latitude, min/max longitude), start/end time of 
the period of interest, min/max depth, name of the output file and directory where to find it. In this case, we refer to 
the Western Tropical Atlantic bounding box. 

copernicusmarine.subset( 

  dataset_id="cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m ", 

  variables=["so"], 

  minimum_longitude=-70, 

  maximum_longitude=-30, 

  minimum_latitude=-5, 

  maximum_latitude=20, 

  start_datetime="2023-06-01T00:00:00", 

  end_datetime="2023-06-30T23:59:59", 

  minimum_depth=0, 

  maximum_depth=0.5, 

  output_filename = "cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2023.nc", 

  output_directory = "copernicus-data" 

) 

 

By executing the cell, you will be asked to provide username and password of your Copernicus Marine account: after 
inserting, the download of the file containing the monthly averaged salinity field for Jun 2023 given by the GLO-PHY NRT 
system. Once completed, the output file cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2023.nc will be 
accessible through the local folder copernicus-data and ready to be used. 

https://help.marine.copernicus.eu/en/collections/4060068-copernicus-marine-toolbox
https://jupyter.org/
https://help.marine.copernicus.eu/en/collections/4060068-copernicus-marine-toolbox
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2.1.2.1. Example on how to download the Copernicus Marine GLO-PHY product from the 
Copernicus Marine Data Store using the GUI 

In this section, we illustrate how to download the monthly chlorophyll for Jun 2023 as provided by the  
OCEANCOLOUR_GLO_BGC_L4_NRT_009_102 product directly from the Copernicus Marine Data Store by using the GUI, 
in the Western Tropical Atlantic bounding box. 

Step 1: Access to the GLO-OC-SAT NRT product main page from the Copernicus Marine Data Store (hyperlinked in 
Section 2.1.1). Visualization of the options for accessing relevant information about the selected product. As shown in 
Figure 2, the GLO-OC-SAT NRT main page provides an overview of the most relevant information related to the Global 
Ocean Color L4 satellite product, including the options for accessing the data. 

Option 1: by clicking on “Data Access” tab, you will be redirected to a second page that gives the list of available datasets 
with interfaces for downloading associated data (Figure 3):  

• Subset, which is the new function for interactively select total or a portion of the interested region. 

• Files, that returns the data archive structure of the selected dataset. 

• Maps, that returns WMTS file that you might export to use in your dedicated webservice. 

 

Figure 2: GLO-OC-SAT NRT product main page through the Copernicus Marine Service. 

https://data.marine.copernicus.eu/product/OCEANCOLOUR_GLO_BGC_L4_NRT_009_102/description
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Figure 3: Option 1 for accessing Copernicus Marine data using a) subset (in orange), b) files (in green) or c) maps (in red). 

Option 2: by clicking on “Explore in MyOcean Pro” tab, you will be redirected to the MyOcean Pro Viewer webpage that 
shows the 2D map of the selected field (Figure 4). The viewer gives the opportunity to: 

• Add any new field as new layer. 

• Download the file by selecting the bounding box and the range of dates. 

• Access to information about the product/dataset, customize the map, save, and export for next uses. 

Once the spatio-temporal information for the selected variables is inserted into the GUI, you might launch the download 
of the file. 

 

Figure 4: Option 2 for accessing Copernicus Marine data using the MyOcean Pro Viewer functionalities. 

Additional information on how to access and download Copernicus Marine data are provided in the Copernicus Marine 
E-Learning Material and at the page dedicated to the MarineData4SouthAmerica. 

https://marine.copernicus.eu/services/user-learning-services/tutorials
https://marine.copernicus.eu/services/user-learning-services/tutorials
https://events.marine.copernicus.eu/marinedata4southamerica-2024
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2.2. QGIS Software 

2.2.1. Installation of QGIS 

The GIS software used for this training is the QGIS software in its version 3.28-Firenze Long Term Release (last available 
version as accessed on 15/01/2024).  

QGIS is the widely adopted open-source GIS software, supported by the Open Source Geospatial Foundation (OSGeo) 
and available on many Operating Systems like Windows, MacOS, Linux, IOS and Android.  

To install QGIS, follow the instructions at dedicated installation page and download the OSGeo4W Network Installer. 

Then, choose the Express Install and Check QGIS and GDAL boxes before launching the Installation. 

A video explaining the basic steps for downloading and installing QGIS is available at the page dedicated to Copernicus 
MarineData4SouthAmerica. 

2.2.2. Installation of the CMEMS-NetCDF plugin and example on how to load a NetCDF file 

The Copernicus Marine Service makes available the CMEMS-NetCDF plugin, which enables the handling of data in 
NetCDF format. The user can follow the instructions on how to install it in QGIS by accessing the dedicated webpage 
prepared by the Copernicus Marine Team at the E-Learning section, which makes available: 

• The link to download the plugin and 

• The user manual, 

together with some tutorial on how to use it. 

To install the CMEMS-NetCDF plugin, from the top menu of QGIS select Plugins > Manage and Install Plugins…. Then, a 
window Plugin | Install from ZIP appears, and the user can browse through her/his personal folder to select the zip file 
containing the CMEMS-NetCDF plugin as downloaded from the Copernicus Marine E-Learning Section (link in Appendix). 
Finally, select Install Plugin. Figure 5 visualizes the main steps performed though the GUI. The same steps can be 
performed in case an update of the plugin through a new zip file needs to be done. Once installed/updated, the CMEMS-
NetCDF icon appears in the QGIS toolbar, and it is ready to be used. 

 

Figure 5: Steps for installing / updating a the CMEMS-NetCDF plugin.  

Once clicking on the CMEMS-NetCDF icon available in the toolbar or selecting Plugins > NetCDF2GIS > Import NetCDF 
files from the QGIS top menu, a GUI appears with functions to load and explore the NetCDF file structure and semantic, 
as schematized in Figure 6. 

https://docs.qgis.org/3.28/en/docs/index.html
https://docs.qgis.org/3.28/en/docs/index.html
https://qgis.org/fr/site/forusers/download.html
https://qgis.org/en/site/forusers/alldownloads.html#osgeo4w-installer
https://marine.copernicus.eu/services/user-learning-services/qgis-plugin-cmems-netcdf
https://marine.copernicus.eu/services/user-learning-services/qgis-plugin-cmems-netcdf
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Figure 6: Overview of the CMEMS-NetCDF plugin GUI. 

2.2.3. Additional plugins useful for this training 

In the following, the list of additional plugins that can support the implementation of the proposed exercises. To install 
them, open the QGIS software and click on Plugins > Manage and install Plugins in the top menu. Once opened, it is 
necessary to type the name of the plugin of interest, search among the listed of proposed one and launch the installation 
by clicking on “Install Plugin” (or “Reinstall Plugin to refresh it in case already present in the local computer). 

1. The QuickMapService is developed by NextGIS and allows to easily add basemaps and geoservices. Details are 
given in the QuickMapServices webpage. 

2. Lat Lon Tools is a plugin that facilitates the query, capture and zoom to coordinates of your selected region. 
Details are given in the Lon Lat Tools plugin webpage. 

3. Terrain Profile is a plugin that allows to extract profiles over a raster. This can be extremely useful for a first 
outlook of the general information provided by a given field or for intercomparing different datasets on the 
same track. Details are given in the dedicated Terrain Profile plugin webpage. 

https://plugins.qgis.org/plugins/quick_map_services/
https://plugins.qgis.org/plugins/latlontools/#plugin-details
https://plugins.qgis.org/plugins/profiletool/#plugin-about
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3. Launching a QGIS project and importing a basemap 

This section opens with some basic instructions on how to create a new project – that will be used during the training 
session – and play with the available basemaps for supporting the visualization & analysis of the Copernicus Marine 
data. 

3.1. Open QGIS and create a new empty project 

On the top menu, click on Project > New to create a new project (Figure 7). 

 

Figure 7: Launching a new project on QGIS. 

Finally, save the project by selecting, in the top menu, Project > Save as > <name>.prj in a dedicated folder in your 
computer. 

3.2. Overview of installed plugins access and configuration of a basemap 
through QuickMapServices 

Pre-installed plugins –QuickMapServices, Lat Lon Tools, CMEMS-NetCDF  – can be invoked by clicking on Plugins in the 
top menu or directly clicking on the corresponding icons, as schematically shown in Figure 8. 

 

Figure 8: Options for invoking plugins: a) through top menu “Plugins” command or b) through specific icons. 

The QuickMapServices is configured to help the user to easily geolocate any specific area. By clicking the corresponding 
icon in the toolbar, the user can select the preferred basemap on a pre-loaded list. In this training, we will use the 
Google Hybrid map. 

The Lat Lon Tolls are here used to support the creation of polygon shapefiles according to given coordinates. 

The CMEMS-NetCDF plugin is, finally, used for opening and loading the NetCDF files related to Copernicus Marine 
products as described in Section 2.1.1.  
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4. Loading the Copernicus Marine Products 

This section illustrates the steps for loading and visualizing one of the Copernicus Marine Products, whose detailed list 
is given in Section 2.1.1, using the CMEMS-NetCDF plugin. We will show how to open and visualize salinity and the 
currents in the Western Tropical Atlantic region by opening the 2 files: 

• cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2023.nc 

• cmems_mod_glo_phy-cur_anfc_0.083deg_P1M-m_Jun-2023.nc 

Both examples are provided with the scope to give to the reader a general overview on how to deal with 2D (and 
applicable to 3D as well) files, considering scalar variable like salinity (so) and vectorial variables like currents (cur). 

It is important that at this step the reader has pre-installed the CMEMS-NetCDF plugin, as described in Section 2.2.2. 

4.1. Steps for loading and display salinity field 

The objective of this section is to illustrate how to load and display the file related to salinity in Jun 2023 from GLO-PHY 
NRT cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2023.nc using the CMEMS-NetCDF plugin.  

A representation of the workflow is given in Figure 9. 

Step 1: clicking on “+”, you may load the file you are interested in. Automatically, this function opens a window where 
you may browse in your local archive for selecting the NetCDF file. 

Step 2: on the right side of the CMEMS-NetCDF application window, you will see the list of loaded metadata from the 
selected file. By doing a right click on the selected variable (in this case, the so variable related to the salinity), a menu 
will appear with option to select “Add Layers” or “Sequence Layers”. 

Step 3: by selecting “Add Layers”, the application opens a new window with details on the selected variable.  

Step 4: here, you may select the timestamp (and depth if available, but here not shown) and finally add to your QGIS 
project. 

Step 5: clicking on “Add” the layer will be displayed in the QGIS main window. 

 

Figure 9: Steps to load the salinity NetCDF file using CMEMS-NetCDF plugin. 

Once the file has been loaded and the layer has been added, the salinity field will be displayed on QGIS map canvas. The 
workflow to customize the map is shown in Figure 10, while the final result is shown in Figure 11. 
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Step 1: the active layer “so_01062023_0000” is displayed in QGIS after loading the NetCDF file through the CMEMS-
NetCDF plugin. It is shown with default colormap. 

Step 2: to customize it, do right click to visualize the right menu, with list of functions to modify the active layer. 

Step 3: select “Properties”. 

Step 4: after selecting, the menu as shown in the figure is displayed. You may modify the colormap, min/max values for 
the salinity and number of intervals for colour distribution as you prefer. 

 

Figure 10: Overview of the loaded map and access to layer properties. 

 

Figure 11: Final visualization of the map, after customizing layer properties. 
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4.2. Steps for loading and display currents field 

The objective of this section is to illustrate how to load and display the file related to currents in Jun 2023 from GLO-
PHY NRT cmems_mod_glo_phy-cur_anfc_0.083deg_P1M-m_Jun-2023.nc using the CMEMS-NetCDF plugin.  

Steps described in Figure 9 are applicable to the 2 variables uo and vo as given by the file related on currents. So, you 
may display the 2 fields in the QGIS main window and customize the colours for the 2 scalar variables. CMEMS NetCDF 
plugin offers the possibility to vectorize uo and vo to build the map with currents direction and intensity. 

Step 1: in the CMEMS NetCDF plugin window, select the Layer tab. You will see the list of loaded variables. 

Step 2: for multi-selecting uo and vo, do “CTRL+click” on the layers. Then, doing “right click”, a menu is displayed. Select 
“Vectorize”. 

Step 3: the vectorization provided by the plugin allows to combine uo and vo for displaying currents direction and 
intensity. This is set through a dialog window, where you may specify the input layers (U Component: uo; V 
Component:vo), the type of normalization (in this case, we are interested in building “Currents” map), the number of 
subsampled arrows that will be shown (in this case, x10) and finally the output directory and raster file. 

These steps are summarized in Figure 12. The final result is shown in Figure 13. 

 

Figure 12: Steps for the vectorization of uo and vo. 

 

Figure 13: Final visualization of the map of currents, associated to layer Arrow_3.gml, displayed in the Layer tab on the left. 
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5. Technical notes about specific QGIS functions used during 
the training session 

This section aims at providing some technical notes about used QGIS functions and plugins for performing the 
MarineData4SouthAmerica Training session. Demonstrative application is provided in the dedicated video. 

5.1. Characterization of the physical and biogeochemical conditions in the 
Western Tropical Atlantic in Jun 2023 

In this exercise, we will illustrate how to use QGIS functionalities to perform some geospatial analysis for characterizing 
the environmental conditions in the Western Tropical Atlantic using a set of Ocean Variables (Ovs): salinity (from GLO-
PHY NRT), chlorophyll, phytoplankton, and oxygen (from GLO-BGC NRT). 

• Loading upstream data in QGIS using CMEMS-NetCDF plugin. 

• Creating transects for the extraction of the physical and biogeochemical variables along the coastline. 

• Calculating the basic metrics of the selected Ovs close to the Amazon River mouth. 

5.1.1. Loading input data 

To load the input data, we use the CMEMS-NetCDF QGIS plugin as described in Section 4.1. The NetCDF files that are 
here loaded are related to: 

• Salinity S (cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2023.nc), provided by the GLO-PHY NRT 
system. 

• Chlorophyll concentration CHL (cmems_mod_glo_bgc-pft_anfc_0.25deg_P1M-m_Jun-2023.nc), provided by 
the GLO-BGC NRT system. 

• Phytoplankton concentration PHYC (cmems_mod_glo_bgc-pft_anfc_0.25deg_P1M-m_Jun-2023.nc), provided 
by the GLO-BGC NRT system. 

• Dissolved oxygen O2 (cmems_mod_glo_bgc-bio_anfc_0.25deg_P1M-m_Jun-2023.nc), provided by the GLO-
BGC NRT system. 

The GLO-PHY NRT provides salinity at the horizontal resolution of 1/12°, while the GLO-BGC NRT provides green Ovs at 
the horizontal resolution of 1/4°. The OVs once loaded using the CMEMS NetCDF plugin will be displayed in the QGIS 
main window as shown in Figure 14 to Figure 17. 

 

Figure 14: Salinity S in Jun 2023. 
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Figure 15: Dissolved oxygen O2 in Jun 2023. 

 

Figure 16: Phytoplankton concentration in Jun 2023. 
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Figure 17: Chlorophyll concentration in Jun 2023. 

5.1.2. Exploring the ocean ecosystem conditions by using transects along the coastline 

In case of multiple sources of information, like in this case as provided by the 4 different datasets, an user may be 
interested in performing some extraction of oceanographic values along a specific section. In this case, it is possible to 
efficiently use the Terrain Profile plugin. 

Step 1: Selection of the Terrain Profile plugin. Once activated, a dedicated window containing the layout of a chart and 
a board for layers appear as in Figure 18. 

 

Figure 18: Terrain Profile tool: board of the layers and chart layout, as appearing at the launch of the plugin. 

Step 2: Extraction of the profile over the given raster. The user can interactively specify the section along which the 
Terrain Profile tool is going to extract the corresponding values. An example is given in Figure 19. 

Step 3: Automatic extraction of sections perpendicular to the coastline. Another more sophisticated and automatic 
approach for extracting OVs along sections is given by the function “Transects”.  

• 3.1. First, we create a baseline parallel to the Guiana coastline using a “New Shapefile” – type “Line String”. 

• 3.2. Now we create the control points for the section by selecting “Processing” → “Toolbox” → “Densify by 
Interval”. An example of settings is given in Figure 20. 

• 3.3. Finally, using “Transects” and giving settings as in Figure 21, it is possible to visualize 3 transects that are 
collocated almost perpendicular to the selected coastline. The final result is shown in Figure 22. 
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Figure 19: Extraction of S, O2 and CHL values along a selected section. 

 

Figure 20: Setup of "Densify by Interval" for the automatic creation of sections along the coastline. 

 

Figure 21: Setup of “Transects” function. 
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Figure 22: Visualization of 3 sections automatically built using "Transects" function. 

Step 4: Extraction of OVs along the new sections. The last step of the processing consists of extracting the OVs along 
the sections by using the tool “Profiles by lines”. From the active layers and the defined sections, it is possible to 
generate the interpolated OVs following the settings reported in Figure 23. Once the extraction is performed, the 
sections are displayed, one set per each selected variable. Each raster can be queried through its table of attributes that 
show the numerical values of the variables along a selected section. An example is given in Figure 24. 

 

Figure 23: Setup of the Batch Process dedicated to extraction of profiles from the given sections. 

 

Figure 24: Visualization of extracted OVs layers and CHL table as example. 
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5.1.3. Basic ocean variable derived quantities at the Amazon River mouth 

In order to monitor effectively the spatial distribution of ocean variables at the Amazon River mouth, it is possible to 
perform some basic geospatial analysis in a more localized area. 

Step 1: Creation of a new bounding box at the Amazon River mouth. The list of commands to execute is: “Layer” → 
“Create” → “Create new shapefile layer”. Once selected, a window is opened for the setup of: 

a) The name of the new shapefile layer (“delta.shp”). 
b) The type of shapefile layer (LineString). 

Finally, the new shapefile layer appears in the Layer board. To activate it, it is necessary to select “Toggle Editing” option, 
and draw the polygon in the region of interest. The final result is shown in Figure 25. 

 

Figure 25: Creation of a new shapefile "delta" at the Amazon River mouth. 

Step 2: Clipping the active layers over the new shapefile. The list of commands to execute is: “Raster” → “Extraction” 
→ “Clip raster by mask layer”. Once selected, a window is opened for the setup of the batch process aimed at: 

a) Taking the active layers S, CHL, O2 and PHYC as input fields. 
b) Specifying “delta” shapefile as reference mask layer. 
c) Specifying the output shapefiles. 

Once run, the 4 new subsets are created. An example of the final results is shown in  

 

Figure 26: Visualization of the subset active layers over the delta bounding box (new fields are in gray). 

Step 3: Compute averaged quantities over the delta bounding box. The list of commands to execute is: “Processing” → 
“Toolbox” → “Zonal Statistics”. Once selected, a window is opened for the setup of the batch process aimed at: 

a) Taking the active layers S, CHL, O2 and PHYC on the delta bounding box as input fields. 
b) Specifying the “delta” shapefile as reference mask. 
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c) Specifying the list of metrics to compute”. 
d) Defining the output shapefiles. 

Once run, the 4 statistical shapefiles are created. To check the values, it is possible to select the corresponding table of 
attributes. An example of output is given in Figure 27. 

 

Figure 27: Visualization of an example of computed metrics for the CHL: mean, min, max, range and variance. 

5.2. Characterization of the Amazon River plume 

In this exercise, we will illustrate how to use QGIS functionalities to perform some geospatial analysis for characterizing 
the Amazon River plume, considering 2 specific periods: Jun 2021, during which an extreme flood occurred (Espinoza et 
al., 2022), and Jun 2023, characterized by prolongated droughts. The following steps will be described: 

• Loading upstream data in QGIS using CMEMS-NetCDF plugin. 

• Evaluating the physical conditions of the Amazon River plume region of influence (SSS < 35 PSU). 

• Visualization and analysis of the biogeochemical conditions. 

5.2.1. Loading input data 

To load the input data, we use the CMEMS-NetCDF QGIS plugin as described in Section 4.1. The NetCDF files that are 
here loaded are related to: 

• Physical sea state: 
o Salinity S in Jun 2023 (cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2023.nc), provided by 

the GLO-PHY NRT system. 
o Salinity S in Jun 2021 (cmems_mod_glo_phy-so_anfc_0.083deg_P1M-m_Jun-2021.nc), provided by 

the GLO-PHY NRT system. 

• Biogeochemical conditions: 
o Chlorophyll satellite observation at 4 km resolution (cmems_obs-oc_glo_bgc-plankton_my_l4-multi-

4km_P1M_Jun-2021.nc and cmems_obs-oc_glo_bgc-plankton_my_l4-multi-4km_P1M_Jun-2023.nc). 
o Chlorophyll high resolution satellite observations at 300 m resolution (cmems_obs-oc_glo_bgc-

plankton_my_l4-olci-300m_P1M_Jun-2021.nc and cmems_obs-oc_glo_bgc-plankton_my_l4-olci-
300m_P1M_Jun-2023.nc). 

After loading them on QGIS, they will be automatically displayed and the user can customize the properties (e.g., palette, 
scale, etc.).  

5.2.2. Evaluating the physical conditions of the area of influence of the Amazon River 

A first basic analysis to understand the peculiar differences between the sea surface salinity (SSS) in the 2 reference 
periods is given by computing difference of the fields: 

∆𝑆𝑆𝑆 = 𝑆𝑆𝑆𝐽𝑢𝑛 2023 − 𝑆𝑆𝑆𝐽𝑢𝑛 2021                                                                          (1) 

To compute Eq.1, we use the “Raster Calculator” following the steps as given and displayed in Figure 28. 
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Figure 28: Steps for computing the difference in salinity between Jun 2023 and Jun 2021. 

After running the process, the new layer “diff_so” is displayed in the QGIS main window as  

 

Figure 29: SSS difference considering the corresponding fields in Jun 2023 and Jun 2021, computed according to Eq. 1. 

We can now extract the region of influence of the Amazon River plume by considering the region within the 35 PSU 
contour. The contour lines are automatically extracted by QGIS through the function “Contour”. 

Step 1: Setup of the Contour function. The list of commands to execute is: “Raster” → “Extraction” → “Contour”. Once 
selected, a window is opened for the setup of batch process aimed at: 

a) Prescribing the input layers to process (i.e., “so_01062023*” and “so_01062021*”). 
b) Defining the interval between contour lines (in this case, we consider 1). 
c) Giving the name to the variable that will represent the contour line (SSS). 
d) Giving the name to the final output layers. 

The main settings are then shown in Figure 30. 
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Figure 30: Settings for running the contour extraction as batch process. 

After extracting the contours, the QGIS main window is refreshed showing the contour lines for both SSS layers (Figure 
31). 

 

Figure 31: Visualization of contours for SSS in Jun 2021 (blue lines) and Jun 2023 (red lines). 

Finally, we can filter the contours that are within the 35 PSU: this is done by working directly on both layers 
“countour_so_01062021*” and “countour_so_01062023*” displayed in Figure 31. This is done by selecting the “Filter” 
option just in selecting the target layer to process. Steps are summarised in Figure 32. 

 

Figure 32: Steps for the extraction of the contour lines from SSS field (example for the Jun 2023 SSS). 

With the same set of commands used for filtering the contours as previously described and represented in Figure 32, it 
is possible to select only the contour at 35 PSU, in order to display the region that is characterized and affected by the 
Amazon River plume. It implies the modification of the Filter Expression as follows: 

"SSS" = 35 

Once the filter is run for both SSS layers, the result is refreshed in the QGIS main window as in Figure 33. 
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Figure 33: Visualization of the 35 PSU contour line for SSS in Jun 2021 (blue line) and Jun 2023 (red line). 

5.2.3. Visualization and analysis of the biogeochemical conditions in the Amazon River area of 
influence 

The display of the region of influence of the Amazon River plume in the considered period of references facilitates also 
the visualization and analysis of the biogeochemical water properties.  

We first consider the chlorophyll satellite observations at 4 km resolution (expressed in mg/m3) (Figure 34 related to 
Jun 2021 and Figure 35 related to Jun 2023):  

 

Figure 34: Visualization of the CHL satellite multi-sensors observation and SSS contour at 35 PSU in Jun 2021. 
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Figure 35: Visualization of the CHL satellite multi-sensors observation and SSS contour at 35 PSU in Jun 2023. 

We can be interested in computing averaged OVs in the region characterized by the Amazon River plume, in particular 
along the coastline characterized by SSS < 35 PSU. To do this, we consider, as example, the raster file related to SSS in 
Jun 2023 and we perform the following steps. 

Step 1. Conversion raster to vector. The list of commands to execute is: “Raster” → “Conversion” → “Polygonize (Raster 
to Vector)”. Once selected, a window is opened for the setup of a process aimed at: 

a) Taking “so_01062023*” raster as input layer. 
b) Saving the output (“so_vector”). 

After running the process, a discrete map of polygons is displayed in the QGIS main window. As additional step, the set 
of polygons needs to be fixed geometrically in order to remove potential irregularities that can compromise the next 
analysis. The list of commands to execute is: “Processing” → “Toolbox” → “Fix geometries”. Once selected, a window 
is opened for the setup of a process aimed at: 

a) Taking “so_vector” as input layer. 
b) Saving the output (“so_vector_fix”). 

The result of this step is displayed in Figure 36. 

 

Figure 36: SSS layer for Jun 2023 transformed in polygons. 

Step 2: Filtering region with SSS < 35 PSU. From the layer with polygons, we invoke the option “Filter”. A new window 
is opened – “Query Builder” – and we setup the formula to detect all polygons that are characterized by SSS < 35 PSU 
(Figure 37). 
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Figure 37: Filtering polygons characterized by SSS < 35 (here the reference variable is called "DN"). 

The new map of polygons that visualize only the ones with SSS < 35 PSU is shown in Figure 38. 

 

Figure 38: Visualization of polygons that are characterized by SSS < 35 PSU. 

From this point on, it is possible to perform easily any geospatial analysis in any or in the whole area of influence of the 
Amazon River plume. The next step will show how to setup a coastal analysis of the physical sea conditions. 

Step 3: Creation of a target region in the Amazon River delta. From the available polygons as in Figure 38, we are 
interested in focusing on the Amazon River delta. To subset the polygons, it is necessary to create an additional shapefile 
(as polygon) that will be used for selecting the region of interest. The list of commands to execute are: “Layer” → “Create 
layer” → “New shapefile layer”. It will open a new window where we specify: 

a) The name of the new shapefile layer (“delta”). 
b) The type of geometry (“Polygon”). 

After prescribing these settings, a new shapefile is displayed in the Layer board. Once activated through the “Toggle 
Editing”, it is ready to be used. We digitize a shape (“Digitize with segment”) in the delta region. To save it, we deactivate 
the “Toggle Editing”. The output is as in Figure 39. 
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Figure 39: Visualization of the polygon in the delta region (in pink). 

The last operation for this step is to cut the polygons in the delta region and unifying them. The list of commands to 
execute is: “Vector” → “Geoprocessing Tools” → “Intersection”. Once selected, a new window is opened, that requires: 

a) The specification of the input layer (“so_vector_fix”). 
b) The specification of the overlapping layer (“delta”). 
c) The output layer (“delta_polygon”). 

Once run, a refreshed map is shown, with polygons in the delta region. By selecting “Vector” → “Geoprocessing Tools” 
→ “Dissolve” in the last created layer, it is possible to merge the set of polygons in new one to create a continuous 
irregular region, ready to be used for further analysis (“delta_polygon_dissolve”) (Figure 40). 

 

Figure 40: Visualization of the delta region of interest. 

Step 4: Calculation of relevant metrics. Let’s consider the following layers: 

• so_01062023_0000 related to SSS Jun 2023 from GLO-PHY NRT. 

• CHL_01062023_000 related to CHL Jun 2023 from GLO-OC SAT NRT product. 

We use the created polygon to cut the 2 fields over it and compute relevant metrics. We run the “Clip by mask layer” 
(e.g., “Raster” → “Extraction” → “Clip by mask layer”) in batch mode, giving: 

a) The 2 layers as input ones. 
b) As mask, the “delta_polygon_dissolve” layer. 
c) The output filename with tag “delta_” for the results. 
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After running the process, the 2 maps are displayed in the QGIS main window for SSS () and for CHL (). 

 

Figure 41: SSS for Jun 2023 in the Amazon River delta. 

 

Figure 42: CHL for Jun 2023 in the Amazon River delta. 

To compute some basic quantities aimed at characterizing the delta region, we run the “Zonal Statistics” function (e.g., 
“Processing” → “Toolbox” → “Zonal Statistics”). After selecting as input layers: 

a) The reference mask (“delta_polygon_dissolve”), 
b) The 2 physical layers (“so_01062023*” and “CHL_01062023*”), 

and tag the output layers with “stats_”, we run the batch process to compute mean, maximum, minimum and other 
quantities for characterizing the physical conditions in the delta region. By opening the “Attribute table” of the 2 
outputs, we are able to visualize the metrics for SSS (Figure 43a) and for CHL (Figure 43b). 
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(a) 

 

(b) 

Figure 43: Essential metrics for a) SSS and b) CHL in the Amazon River Delta in Jun 2023. 

We then consider the chlorophyll satellite observations at 300 m resolution (expressed in mg/m3) (Figure 44 related to 
Jun 2021 and Figure 45 related to Jun 2023). Having only a distribution of values along the coastline, the CHL at 300 m 
resolution is well suited to be investigated by using the “Terrain Profile” plugin or the transects function, as shown in 
Section 5.1.2. 

 

Figure 44: Visualization of the CHL satellite OLCI observation and SSS contour at 35 PSU in Jun 2021. 

 

Figure 45: Visualization of the CHL satellite OLCI observation and SSS contour at 35 PSU in Jun 2023. 
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Conclusions  

This report focused on presenting the way we can use the Blue and Green Ocean products provided by the Copernicus 
Marine Service in QGIS for monitoring the Amazon River region of influence, its plume and its delta. 
The document is divided in 3 main parts:  

• The first part gave an overview of the study area and the description of the Copernicus Marine products 
specifically used in the demonstrative phase: the Global Ocean Physics Analysis and Forecasting system, the 
Global Ocean Biogeochemical Analysis and Forecasting system, the Ocean Color satellite products (L4) at 4 km 
resolution and the last high resolution one at 300 m.  

• The second part described the QGIS software, focusing particularly on the used plugins: the CMEMS-NetCDF 
plugin for loading, reading, and processing the NetCDF files provided by the Copernicus Marine Service; the 
QuickMapServices for loading basemap used as background of the ocean fields, to improve readability of 
geographical information; the Lon Lat Tools plugin, for easing the query of the map; the Terrain Profile plugin, 
for extracting sections and transects on the fly.  

• The third part showed the main technical implementations discussed also during the training session, providing 
to users an overview on how to display NetCDF files and customize maps, for scalar variables (like salinity) and 
vectorial ones (like currents). It was discussed how to use the Terrain Profile plugin to retrieve OVs information 
by interacting with the displayed map as well as how to automatize the generation of transects using the native 
QGIS functions. It was shown also how to characterize the Amazon River plume, in particular by comparing the 
SSS fields in Jun 2021 (during the most extreme flood occurred in the South America and discussed by Espinoza 
et al. (2022)) and in Jun 2023 (recently time, affected by severe droughts). 

These technical notes complemented the training session given during the MarineData4SouthAmerica Event, organized 
by Mercator Ocean International for the Copernicus Marine Service on 22-23/02/2024. 
 
Please, visit the dedicated User Learning Service promoted by the Copernicus Marine Service to access the e-learning 
material and discover other interesting exercises. 
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Copernicus Marine QGIS plugin installation: https://marine.copernicus.eu/services/user-learning-
services/qgis-plugin-cmems-netcdf  
 
Copernicus Marine Toolbox: https://help.marine.copernicus.eu/en/collections/4060068-copernicus-marine-
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Copernicus Webinar - MarineData4SouthAmerica2024: 

• https://events.marine.copernicus.eu/marinedata4southamerica-2024 
 
CF Conventions: https://cfconventions.org/ 
 
NetCDF: https://www.unidata.ucar.edu/software/netcdf/  
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