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1. Introduction 
1.1. Scope of the document 

MarineData4CoastalMonitoring training event, promoted by Mercator Ocean International in the framework of the 
Copernicus Marine Service, aims at increasing user uptake and awareness of coastal environments in all regions of 
the world by sharing applications of the Copernicus Marine Service products in ecosystem monitoring studies.  

Technically, here it is shown how to use QGIS for: 

• Understanding Copernicus Marine data through mapping functions and 

• Performing some spatial analysis to target the topics covered by this training, that are coral bleaching and 
eutrophication. 

The technical material here described is complementary to the tutorial videos available on the Copernicus Marine 
Service YouTube page. 

This document has been prepared by Dr. Stefania A. Ciliberti (NOW Systems, Madrid). 

1.2. Structure of this tutorial 

This tutorial is organized in 2 parts: 

• Section 2 gives an overview on coral bleaching, focusing on African coastal area of Kenya and Tanzania. 

• Section 3 discusses eutrophication, showing how to use geospatial tools to analyze physical and 
biogeochemical conditions in the Western Mediterranean, taking the Ebro Delta as example. 

Exercises here presented use some technical information as discussed in  

TD1: Copernicus Marine Service – Training Workshop | QGIS installation notes and plugin configuration, by Dr. 
Stefania A. Ciliberti (NOW Systems, Madrid). 

  

https://www.youtube.com/@copernicusmarineservice1453/videos?cbrd=1
https://www.youtube.com/@copernicusmarineservice1453/videos?cbrd=1
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2. Coral bleaching: the Kenyan coral reef ecosystem  
2.1. Introduction 

Coral bleaching is a phenomenon where corals, under stress, expel the symbiotic algae (zooxanthellae) living in 
their tissues. Since these algae provide corals with food through photosynthesis and give them their color, their 
loss leads to bleaching. The primary causes of coral bleaching must be addressed to extreme weather events due 
to anthropogenic global warming, pollution and ocean acidification (Hughes et al. 2018). 

The UN Environment Program (UNEP) promotes international cooperation to support the protection, sustainable 
management and restoration of coral reefs, and related ecosystems. As shown in Figure 1, coral reefs are 
distributed in tropical and subtropical oceans around the world, primarily between the Tropic of Cancer and the 
Tropic of Capricorn. These regions provide warm, shallow waters that are ideal for coral growth. Coral reefs are 
critically important for marine biodiversity, coastal protection, and local economies, particularly through tourism 
and fishing.  

This training session is going to focus on discuss examples on how to use QGIS-based tools and Copernicus Marine 
products for monitoring Kenya-Tanzania’s coastal region (Figure 2) with focus on Kenyan coral reef ecosystem, 
currently severely impacted by humanitarian and climate crisis due to rising temperatures. 

The Eastern African coastal region is deeply influenced by the East African Coastal Current (EACC), supplied by the 
Northeast Madagascar Current (NEMC). The EACC is influenced by monsoonal wind system, with significant changes 
between the northeast and southwest monsoons. During the Northeast Monsoon (November to March), the EACC 
tends to be weaker, while during the Southwest Monsoon (June to September), the EACC strengths due to the 
prevailing winds. It transports warm water that feeds the coastal ecosystem, interacting with upwelling areas, 
exacerbating thermal stress during periods of high sea surface temperatures and so causing severe coral bleaching 
events. 

 

Figure 1. Distribution of coral reefs around the world (source: UNEP). 
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Figure 2. Kenya-Tanzania study area and main circulation features: the Northeast Madagascar (NEMC) and the 

East African Coastal Current (EACC; thick blue arrow) (reproduced from Schott et al., 2009). The map in 
background refers to sea surface temperature on 16/06/2024 as forecasted by the Global Ocean Physical Analysis 

and Forecasting System. 

Coastal management plays an important role in definition of restoration plans for coral reefs and local biodiversity 
and monitoring water conditions can significantly help in the process. Guan et al. (2015) has proposed 
environmental tolerance limits for coral reefs for 6 EOV: temperature, salinity, nitrate, phosphate, aragonite 
saturation state and light. The Authors found that the global, annually averaged tolerance limits for coral reefs are:  

• For temperature: 21.7-29.6 °C.  

• For salinity: 28.7-40.4 PSU. 

• For nitrate:4.51 μmol L-1.  

• For phosphate: 0.63 μmol L-1.  

• For aragonite saturation: 2.82. 

• For the average minimum light intensity: 450 μmol photons m-2 s-1. 

2.2. Scope of the QGIS application and input data 

In this tutorial, we will learn how to use QGIS for assessing the physical and biogeochemical conditions in the Kenya-
Tanzania region according to tolerance limits as given by Guan et al. (2015), using: 

• Sea surface temperature from the Global Ocean Physics Analysis and Forecasting System. 

• Phosphate concentrations from the Global Ocean Biogeochemical Analysis and Forecasting System. 

Details on used Copernicus Marine products as downloaded from the Copernicus Marine Data Store are given in 
Table 1. The reference bounding box used in this exercise is: [15°S to 1.3°N; 35.45°W to 50°E]. 
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Table 1. Copernicus Marine input data used in the demonstrative QGIS tutorial for the Kenya-Tanzania case study. 

 

Product Dataset Variable and info Reference 

GLOBAL_ANALYSISFORECAST_PHY_001_024 
cmems_mod_glo_phy-
thetao_anfc_0.083deg_P1D-
m 

Temperature 
Bulletin date: 
08/06/2024. 
Timeseries: from 
08/06 (forecast 
day 1) to 17/06 
(forecast day 10). 

Le Galloudec et 
al. 2023 

GLOBAL_ANALYSISFORECAST_BGC_001_028 
cmems_mod_glo_bgc-
nut_anfc_0.25deg_P1D-m 

Phosphate: 
Bulletin date: 
08/06/2024. 
Timeseries: from 
08/06 (forecast 
day 4) to 17/06 
(forecast day 10). 

Lamouroux and 
Tonani, 2023 

 

2.3. QGIS implementation 

2.3.1.  QGIS implementation 

Before starting with the implementation of the proposed exercise, it is necessary to follow some preliminary steps 
as briefly reported here: 

• Launch QGIS. 

• Create a new project: Project → New. 

• Save it in your local working folder (in this way, all QGIS temporary and working files are properly collected 
there, and you will easily manage them): Project → Save Project As (and complete). 

Then, you are ready to start with the implementation of the exercise. 

2.3.2. Loading input data 

To load input data, consisting of NetCDF files related to products as listed in Table 1, use the CMEMS-NetCDF plugin, 
following instructions as in [TD1]. 

• Configure a basemap: from the icon bar, select QuickMapService → Search QMS → Google Satellite. 

• Load the NetCDF files to continue the exercise: from the menu, select Plugins → NetCDF2GIS → Import 
NetCDF Files (alternatively, you may select the plugin icon from the main bar). 

• From your local folder with data, select the NetCDF files according to [TD1]. 

After loading, 3 groups of layers are displayed: 

• The Google Satellite basemap. 

• thetao related to sea surface temperature, from 8 to 17 June 2024 (Figure 3). 

• po4, related to phosphate concentration, from 8 to 14 June 2024 (Figure 4). 
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Figure 3. Sea surface temperature (in Celsius) from the Global Ocean Physical Analysis and Forecasting System on 
08/06/2024. 

 

Figure 4. Concentration of phosphate in sea water (in mmol m-3) from the Global Ocean Biogeochemical Analysis 
and Forecasting System 0n 08/06/2024. 

2.3.3. Analysis of the water conditions in the Kenya-Tanzania coastal area 

The objective is to focus the geospatial analysis in the coastal area of the selected area of study, to characterize 
water conditions according to the method explained in Section 2.1. 

It is necessary first to subset the region of interest and extract the 2 given layers accordingly. 

• Definition of the subregion of interest, in the Kenya-Tanzania coastal area. 
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o Layer → Create Layer → New Shapefile Layer.  

o Assign a name (for example, ken-tan-region.shp) and path where to save the new shapefile. 

o Select Geometry type: Polygon. 

o The created shapefile will be displayed in the Layers Board. Select it and from the icon bar select 
Toggle Editing. By activating it, the shapefile is now open for modification and new icons are 
activated. 

o Select Add Polygon → Digitize with Segment. The polygon can be now drawn in your map. 

o After digitizing the polygon, deactivate Toogle Editing function to save the result. 

The result of this process is briefly represented in Figure 5. 

 

Figure 5. Main steps for defining the subregion of interest in the Kenya-Tanzania coastal area. 

• Extraction of the physical and biogeochemical fields in the coastal region. 

o Extract the given fields over the subregion previously specified as ken-taz-region.shp: Raster → 
Extraction → Clip Raster by Mask Layer. 

o A window pops up. Since we are interested in processing all layers related to temperature and 
phosphate, we will run the process in batches. Select then Run as Batch Process. 

o It opens another window, where you must specify: 

▪ Input layer: in this case, from the available layer, select thetao_* and po4_*. 

▪ Mask layer: by default, QGIS understand that ken-taz-region is the mask to use. To be able 
to apply it to all layers, Autofill → Fill down. 

▪ Clipped (mask): here is the output of the process. It is built by specifying: 
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• Where to save the results. 

• The tag to use for saving the new generated shapefile: for example, specify clip_ 
→ Save. 

• Automatically, Autofill Settings window appears: select Fill with parameters value 
& Input layer. In this way, the resulting file will be automatically generated by 
concatenating the string of the tag (clip_) with the original filename of the layers 
(thetao_* and po4_*). 

The sequence of steps is simplified and represented in Figure 6. 

• Run the batch process. 

• After completed, the resulting new layers will be displayed on the map, as shown in Figure 7. You 
may customize the style of the map – for example, taking the input layers settings as reference 
and applying them to new clip ones. 

 

Figure 6. Main steps for executing geospatial extraction of physical fields in the given mask. 
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Figure 7. Temperature and phosphate layers extracted in the target region. 

• Classification of temperature values according to Guan et al. (2015).  

o To apply environmental tolerance limits for coral reefs as theorized by Guan et al. (2015), it is 
necessary to apply Classification method provided by QGIS from Layer Properties accessible 
through Properties after selecting one layer as example. 

o In Symbology¸ you have the control of the main rendering settings for the selected layer. The 
application of the tolerance threshold is performed by specifying the following settings: 

▪ Render Type: select Singleband pseudocolor. 

▪ Impose Min: 21.7 and Max: 29.6. 

▪ Min/Max Value Settings: select User defined. 

▪ Interpolation: select Discrete. 

▪ Adjust the board Value/Color/Label to fit the limits as specified in Guan et al. (2015). 

The resulting settings for Symbology are shown in Figure 8. Labels can be modified to include also 
text for communication purposes.  

After defining, it is possible to apply the same settings to all temperature layers by copying/pasting 
the modified style. An example of temperature map after re-classification of values according to 
tolerance interval is given in Figure 9. 
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Figure 8. Customized symbology of temperature layers after imposing Guan et al. (2015) tolerance intervals. 

 

Figure 9. Characterization of the tolerance limits for temperature in the Kenya-Tanzania coastal region on 
17/06/2024. 
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▪ Classification of phosphate values according to Guan et al. (2015). 

o Considering the concentration of phosphate in sea water in the given period, a similar analysis as 
performed before for temperature results in creation of a map that shows the area where the 
tolerance interval is still valid. Figure 10 shows the resulting final map that shows the tolerated 
limits in phosphate concentration in the study area. 

 

Figure 10. Characterization of the tolerance limits for temperature in the Kenya-Tanzania coastal region on 
14/06/2024. 
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3. Eutrophication: the Ebro Delta ecosystem 
3.1.  Introduction 

Anthropogenic activities are nowadays the main sources of stress with undesirable ecological effects in coastal 
ecosystems. Increased concentrations of nitrogen (N) and phosphorous (P) that reach coastal waters through rivers 
are the primary cause of eutrophication (Malone and Newton, 2020): it causes changes in the structure and 
functioning of marine ecosystems and reduction in biodiversity, with high impacts on fishery, aquaculture, tourism 
and other coastal activities.  

The European Environment Agency provided a reference document that evaluates the causes, state and 
development of eutrophication in European coastal waters, identifying areas where monitoring is needed to 
improve assessment. Breitburg et al. (2018) analyzed the combined effects of eutrophication and deoxygenation in 
the global coastal ocean: the increase of nutrients from rivers accelerates the proliferation of algal blooms, which 
initially increase the production of oxygen. But when dying, the produced bacteria from the decomposition phase 
are responsible for deoxygenation, with huge and uncontrolled impact on food webs and biodiversity. Figure 11 
shows the worldwide coastal areas affected by eutrophication and deoxygenation from Breitburg et al. (2018): the 
North Sea and Baltic Sea are particularly and seriously affected by eutrophication, as well as several hotspots can 
be found in the Mediterranean and Black Sea. 

Among the parameters measured by satellites, ocean color provides the most useful information for the monitoring 
of eutrophication, and it is a key indicator of ocean health. 

This training session is going to focus on discussing examples on how to use QGIS-based tools and Copernicus 
Marine products for assessing average concentrations of chlorophyll-and oxygen in delta ecosystems: as 
references, we will consider the Ebro Delta (Mediterranean Sea). 

 

Figure 11. Overview of the hypoxic areas (red dots) and ocean regions with minimum oxygen concentration at 300 
m depth (blue areas). Source: Breitburg et al. (2018). 

The Ebro Delta is a natural protected area and the largest wetland areas in the Western Mediterranean, extensively 
used for agricultural purposes and for carrying out shellfish aquaculture (Fernandez-Tejador et al., 2022). The area 
is supplied by nutrients, rich in nitrogen and phosphorus, provided by intensive agriculture activities, and by urban 
and industrial wastewater. They are the main drivers for eutrophication processes in the area, that can cause quality 
degradation in aquatic habitat due to harmful algal blooms (HABs). From an oceanographic point of view, the 
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Northeast Spanish coastline is characterized by the Ligurian-Provencal Current flowing from the North and bringing 
warm and saline waters (Margirier et al., 2020), and the Balearic Front (Figure 12). 

Monitoring of the coastal water quality in areas where eutrophication and consequently HABs is fundamental to 
prevent contamination of farms and loss of biodiversity. 

 

 

Figure 12. Localization of the Ebro River and its delta in the NE Spanish coastal zone. Schematic representation of 
the main circulation patterns characterizing the Western Mediterranean Sea: the Ligurian-Provencal Current and 

the Balearic Front. More details about Western Mediterranean Circulation is Pinardi et al., (2007). The map in 
background refers to sea surface temperature on 16/06/2024 as forecasted by the Global Ocean Physical Analysis 

and Forecasting System. 

3.2. Scope of the QGIS application and input data 

In this tutorial, we will learn how to use of geospatial analysis with QGIS for quantifying average concentrations of 
chlorophyll-a and for assessing the physical state of the Ebro Delta and its coastal region, using: 

▪ Chlorophyll concentration from satellite observations. 

▪ Sea surface salinity from 2 physical modelling systems: the Iberia-Biscay-Ireland Analysis and Forecasting 
System at 1/36° horizontal resolution and the Mediterranean Analysis and Forecasting System at 1/24° 
horizontal resolution. 

Details on used Copernicus Marine products, as downloaded from the Copernicus Marine Data Store, are available 
in Table 2. The reference bounding box used in this exercise is: [40.2°N to 41.55°N; 0.15°E to 1.2°E]. 
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Table 2. Copernicus Marine input data used in the demonstrative QGIS tutorial for the Ebro Delta case study. 

Product Dataset 
Variable and 
info 

Reference 

OCEANCOLOUR_MED_BGC_L4_MY_009_144 
cmems_obs-oc_med_bgc-
plankton_my_l4-olci-300m_P1M 

Chlorophyll 
Monthly 
fields for Jun-
Jul-Aug 2023 

Colella et 
al., 2023 

MEDSEA_ANALYSISFORECAST_PHY_006_013 
cmems_mod_med_phy-
sal_anfc_4.2km_P1D-m 

Salinity 
Monthly 
mean fields 
for Jun-Jul-
Aug 2023 

Clementi et 
al., 2021 

IBI_ANALYSISFORECAST_PHY_005_001 
cmems_mod_ibi_phy_anfc_0.027deg-
3D_P1D-m 

Salinity 
Monthly 
mean fields 
for Jun-Jul-
Aug 2023 

Amo-
Baladron et 
al., 2023 

 

3.3. QGIS implementation 

3.3.1. Preliminary steps 

Before starting with the implementation of this exercise, it is necessary to create a new QGIS project, as already 
described in Section 2.3.1. 

3.3.2. Loading input data 

To load NetCDF files as accessed and downloaded from the Copernicus Marine Data Store, listed in Table 2, use the 
CMEMS NetCDF plugin, following instructions as in [TD1]. 

▪ Configure a basemap: from the icon bar, select QuickMapService → Search QMS → Google Satellite_. This 
basemap visualizes also labels. 

▪ Load the NetCDF files to continue the exercise: from the menu, select Plugins → NetCDF2GIS → Import 
NetCDF Files (alternatively, you may select the plugin icon from the main bar). 

▪ From your local folder with data, select the NetCDF files according to [TD1]. 

After loading, 4 groups of layers are displayed: 

▪ The Google Satellite basemap with labels. 

▪ CHL, related to satellite chlorophyll for June, July and August 2023, from satellite observations at 300 m 
resolution (Figure 13). 

▪ so_ibi, related to sea surface salinity as provided by the Iberia-Biscay-Ireland Analysis and Forecasting 
System, for June, July and August 2023 (Figure 14). 

▪ so_med, related to sea surface salinity as provided by the Mediterranean Analysis and Forecasting System, 
for June, July and August 2023 (Figure 15). 



 
 
 
 

 
 
 
 

16 
Copernicus Marine Service - Training 

 

 

Figure 13. Chlorophyll concentration (in mg m-3) from the Ocean Colour satellite product available in the 
Mediterranean Sea at 300 m resolution. Displayed map is for Jun 2023. 

 

Figure 14. Sea surface salinity (in PSU) from the Iberia-Biscay-Ireland Analysis and Forecasting System, at 1/36 
horizontal resolution. Displayed map is for Jun 2023. 
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Figure 15. Sea surface salinity (in PSU) from the Mediterranean Analysis and Forecasting System, at 1/24 
horizontal resolution. Displayed map is for Jun 2023. 

3.3.3. Characterization of chlorophyll concentration in the Ebro Delta and its coastal 
area  

The scope of this section is to show how to use QGIS for assessing the chlorophyll concentration in the Ebro Delta 
coastal region, to support monitoring of marine health. 

▪ Definition of the reference locations in Fangar Bay (located in the Northern part of the delta) and in Alfacs 
Bay (located in the Southern part of the delta). 

o Layer → Create Layer → New Shapefile Layer. 

o Assign a name (for example, ebro-stations.shp) and path where to save the new shapefile. 

o Select Geometry type: Point. 

o The created shapefile will be displayed in the Layer Board. Select it, and from the icon bar select 
Toggle Editing. By activating it, the shapefile is now open for modification and new icons are 
activated.  

o Select Add Point Feature and start to digitize the stations in the Ebro’s bays. 

o After the digitalization is completed, deactivate Toogle Editing function to save the result. 

The result is shown in Figure 16. Steps to achieve the result are like the ones already introduced in 
Section 2.3.3. 
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Figure 16. Digitalization of the reference monitoring stations (red dots) in the Fangar and Alfacs Bays. 

• Extraction of chlorophyll data in the digitized stations. 

o Processing → Toolbox. It opens a list of functions that can be used for manipulating and processing 
raster values. Search for Sample raster values. 

o Once selected, a new window is opened. To speed up the processing, having 3 reference 
timestamps (i.e., June, July and August 2023 data), it is recommended to run this step in batch. So, 
select Run as Batch Process. 

o It opens another window, where you must specify: 

▪ Input layer: in this case, it is the shapefile containing the digitized stations. 

▪ Raster layer: here, you make a selection considering the function Select from open layer. 
The layers to select are the ones with tag CHL_*. 

▪ Sampled: here you must define the name (tag) and location where to save the result. For 
example, specify points_ as tag of the output shapefiles and allow QGIS to autocomplete 
the filename by concatenating the tag itself with the original filename of the raster layer. 
The sequence of steps is simplified and represented in Figure 6. 

▪ Run the batch process. 

▪ After completed, the resulting new layer will be displayed on the map, as shown in Figure 
18. 

o The values of chlorophyll at station location can be displayed by selecting Open Attribute Table 
from one of the produced new layers. It consists of a table with ID points and chlorophyll value. An 
example is given in Figure 19. Tables can be exported and further processed to get monthly values 
for future analysis. 
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Figure 17. Main steps for executing geospatial interpolation of chlorophyll fields in the given stations. 

 

Figure 18. Chlorophyll concentration for June, July and August 2023 calculated on selected stations in the Fangar 
and Alpacs Bays. On the right: the panel containing some functions, including the Sample Raster Value used in this 

section. 
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Figure 19. Example of resulting table containing chlorophyll values as extracted in the selected points in August 
2023. 

▪ Calculation of Summer averaged chlorophyll concentration and analysis of water quality at given stations. 

o Raster → Raster Calculator. It opens a window – a calculator – where you may type the formula to 
compute the mean of the 3 chlorophyll raster fields. 

o Similarly to the previous point, it is now possible to extract the averaged values of chlorophyll at 
given stations by using the function Sample raster values. The resulting layer is called, for example, 
JJA-points. 

o The final map can be further customized by clustering the computed averaged chlorophyll values 
in groups. This can be done by selecting the corresponding Properties of the JJA-points shapefile. 
You must specify the following settings from Symbology: 

▪ Select Graduated. 

▪ Value: SAMPLE_1 corresponding to chlorophyll values previously computed. 

▪ Method: Color 

▪ Mode: Equal Interval. 

▪ Classes: 5. 

Automatically, the Classes will be displayed. Settings as specified for this exercise are shown in 
Figure 21. A refreshed map with points colored according to specified classes is shown in Figure 22. 
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Figure 20. Setup of formula for computing Summer averaged chlorophyll concentration using Raster Calculator. 

 

Figure 21. Setup of Symbology settings for JJA-points layer. 
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Figure 22. Averaged chlorophyll concentration in JJA 2023 at stations location. 

3.3.4. Assessment of sea surface salinity from multi-model sources 

The scope of this section is to show how to use QGIS for evaluating sea surface salinity in the Ebro Delta coastal 
region. 

• Extraction of sea surface salinity data in reference sections. 

o To easily extract and compare sea surface salinity values over given sections, you may use the 
Profile Tool plugin. This tool is extremely powerful for the visualization of sequence of values in 
digitized sections. An example of how to use it is shown in Figure 23. 
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Figure 23. Example on how to use the Profile Tool for extracting sea surface salinity values from the IBI and MED 
model products in Jun 2023. 
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4. Additional information and conclusions 
This report focused on presenting the way we can use the Blue and Green Ocean products provided by the 
Copernicus Marine Service in QGIS for monitoring coastal areas, and particularly key variables that are relevant for 
characterizing coral bleaching in the Eastern southern Africa coastal region and eutrophication in the Western 
Mediterranean. 

These technical notes complemented the training session (i.e. digital material and live presentation) given during 
the MarineData4CoastalMonitoring Event, organized by Mercator Ocean International for the Copernicus Marine 
Service on 21-22/06/2024. 

Please, visit the dedicated User Learning Service promoted by the Copernicus Marine Service to access the e-
learning material and discover other interesting exercises. 
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• Copernicus Marine QGIS plugin installation: https://marine.copernicus.eu/services/user-learning-
services/qgis-plugin-cmems-netcdf   
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• Copernicus Marine YouTube Channel: https://www.youtube.com/@copernicusmarineservice1453  
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https://events.marine.copernicus.eu/marinedata4-coastal-monitoring-2024  

• CF Conventions: https://cfconventions.org/  

• NetCDF: https://www.unidata.ucar.edu/software/netcdf/  
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